Link from iTunes email generates "Item is not a registered protocol"

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Amir Marandi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Links from an email from iTune generates an ALERT "Item is not registered".  It does not specified what item.  It does not load anything in the window and after clicking ok, it stops and status bar dispalys done. I am runung it under Fedora Core 4.

Reproducible: Always

Steps to Reproduce:
1. Click on a links in email from iTune store.
2. Switch to FireFox window.
3. FireFox displays "Loading...  Please stand by."
4. Immediately an alert window pops up with "Item is not a registered protocal".

Actual Results:  
It just displays the alert message and waits for ok button pressed and then stops loading.

Expected Results:  
To go to iTune website and display the holiday gift guide 2005.

I searched for the solution and found "rtsp is not a registered protocol" message at: http://www.gryzor.com/rtsp.html and followed the reccomendation, but it did not seem to help.
I added this string in "about:config":
network.protocol-handler.app.rtsp
Value: /usr/X11R6/bin/realplay

I am just using the default theme and no extention.  This is a new Fedora Core 4 install.
Component: General → OS Integration
QA Contact: general → os.integration
Summary: Link from iTune email generates "Item is not a registered protocal" → Link from iTunes email generates "Item is not a registered protocol"

Comment 1

12 years ago
Related to/duplicate of bug 269670?

(In reply to comment #0)
> I added this string in "about:config":
> network.protocol-handler.app.rtsp
> Value: /usr/X11R6/bin/realplay

Maybe network.protocol-handler.app.itms (not .rtsp) will work?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to/duplicate of bug 269670?
> 
> (In reply to comment #0)
> > I added this string in "about:config":
> > network.protocol-handler.app.rtsp
> > Value: /usr/X11R6/bin/realplay
> 
> Maybe network.protocol-handler.app.itms (not .rtsp) will work?
> 

I added "network.protocol-handler.app.itms" to about:config but it did not fix it.  I looked at bug# 269670 which is the same message that I get.  I did misspell the "itms" as "item" in the first posting and that was why it was not found in Bugzilla.
Per bug# 269670, "itms: links are supposed to trigger Apple's iTunes application. Do you have it installed?", since this is a Linux install, I do not have iTune installed.  I have iTune installed under WinXP.  Is it possible to map the "itms" to trigger another application?
This is not a Firefox bug, the problem is that the itms protocol isn't handled on your system.  I'm almost 100% certain that itms:// links won't work for non-iTunes apps, since they're links to the iTunes music store....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.