Overlapping text on web pages, occuring with bold or colored text, or links

RESOLVED DUPLICATE of bug 288047

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 288047
12 years ago
8 years ago

People

(Reporter: pauln, Unassigned)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I feel inadequate in reporting this; I don't understand a lot of the technical language used. But I've waded through previous bugs and haven't found anything like this mentioned yet, and it's driving me nuts. I've also adjusted a few of the text settings, font type and font size, to see if this would change anything. And I've tried resizing my browsers (the same thing happens in Mozzilla and Camino). Nothing's worked.

Two things are occurring with text on pages that I regularly visit. First, BOLD text, text other than black, and links to other web pages are overlapping the words in front of them. I've tried copy/pasting these occurrances into other applications to have an example here, but they alwasy paste looking correct. The degree of overlap seems to be 2 characters worth in most cases, but in the paragraph on the top of this page "we do not accept bug reports by email" is covering the "a" and the "t" in the word preceding this phrase. The same thing happens on numerous other sites.

Second, which to me seems related, when I go to reply to a post in a forum (most often www.ChristianForums.com) I have problems with the text as I type. Once I get about half way across the reply form and need to backspace, the letters that I meant to erase do not disappear. The cursor, however, moves back, and when I resume typing I the letters remain that I intended to delete and get pushed along. The end result in the post seems to be erratic, but of course after this occurs I often have no idea what I've actually typed. (However, the problem is not occurring in this form).

Reproducible: Always

Steps to Reproduce:
1. For me it takes no effort to reproduce, and seems completely unpredictable.
2.
3.




Just to note, in the paragraph following this box of this form, the bold words "theme," "Talkback," "your," and "stack" are all at least on character to the left of where they should be, as per the problem above. HOWEVER, the bold "HTML" is formatted correctly. Just to show how random this problem seems.

Comment 1

12 years ago
The URL you gave WFM.

Could you try with a fresh profile and more recent version.

It sounds like something wrong with the font metrics, but I haven't
seen anything like it for years
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> The URL you gave WFM.
> 
> Could you try with a fresh profile and more recent version.
> 
> It sounds like something wrong with the font metrics, but I haven't
> seen anything like it for years

To my knowledge I'm running the newest version for Mac (1.5). What do you mean by try it with a fresh profile (told you I'm ignorant . . . ).

I did try uninstalling it and reinstalling it today. But the problem persists.

 

Comment 3

12 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > The URL you gave WFM.
> 
> To my knowledge I'm running the newest version for Mac (1.5). What do you mean
> by try it with a fresh profile (told you I'm ignorant . . . ).

To make a fresh start with a new profile:
http://kb.mozillazine.org/Profile_Manager#How_do_I_create_a_new_profile.3F

Comment 4

12 years ago
Already updated to Firefox 1.5 for MAC OSX

Comment 5

12 years ago
Probably related to font settings.

Updated

12 years ago
Component: Keyboard Navigation → Layout
Product: Firefox → Core
QA Contact: keyboard.navigation → layout
Version: unspecified → 1.0 Branch

Comment 6

12 years ago
There is bug288047 if you are using Mac OS X 10.4.x.

Comment 7

12 years ago
Created attachment 222339 [details]
Screenshot of description bug
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Created an attachment (id=222339) [edit]
> Screenshot of description bug

That's it. I had hoped that upgrading to 1.5 would have fixed it, and I've tried deleting and reinstalling . . . but it's still doing it. 

Someone suggested I modify the profile . . . I followed the directions I could find but couldn't get them to work . . . couldn't even get into the profile they were talking about.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288047
You need to log in before you can comment on or make changes to this bug.