Incorrect unread message count

RESOLVED DUPLICATE of bug 289674

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 289674
13 years ago
13 years ago

People

(Reporter: mjleahy, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

The Inbox indicates unread messages.  There are no unread messages listed.  When "get mail" is clicked, nothing happens.  Double-click on Inbox and a new window opens with no unread messages indicated, and the account is checked for incoming e-mail.

Reproducible: Always

Steps to Reproduce:
1.Don't know how to reproduce.  
2.
3.

Comment 1

13 years ago
I too am getting this. I started out with 95 unread mails, then when my accounts were checked (no new mails appeared to arrive), the unread count went up to 190. The next time the check happened, the count rose to 285, so the count is incrementing by the last-known number of unread mails. Uninstalling and reinstalling had no effect. I've tried compacting the folder - this did nothing.

Going into a separate folder with unread mails isn't a problem, switching back to the inbox was. Because my mail is checked every minute, as the mail list was trying to be rebuilt, I got a message saying "This folder is being processed - please wait", then when the processing had finally taken place, the number of unread mails dropped to 95 (counted) but displayed 173 under "Local folders".

I am unable to delete mails either through right-clicking or selecting the Delete icon.

I am running Windows XP Home, SP2 and all patches applied up to date, and Thunderbird version 1.5 (20051201)

Comment 2

13 years ago
This started happening to me to, around the same time (mid-December 2005) when I was using 1.0.7.  Then it went away for a while, but resurfaced about a week ago.  I just upgraded to 1.5 and the problem still remains.

Description:  The Windows XP tray shows an envelope icon notification saying "Local Folders has nn new messages" (nn is 41 in my case, but it has increased over the past few days).  However, Local Folders Inbox in Thunderbird shows all messages read (and I also looked at every folder and subfolder and found no unread items anywhere).  When I close Thunderbird the notification goes away. When I restart it, even though I may have retrieved say a single message, and Inbox shows (1), the notification icon reappears with the old (nn) incorrect unread message count.  If I click on another folder, e.g., Sent, the notification disappears, but it reappears after a while (10 minutes maybe, which is the "check new messages" time period).

I did some research and found in regedit that HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UnreadMail had an entry with one of my email addresses that is stored in Local Folders.  It had C:\Program Files\Mozilla Thunderbird\thunderbird.exe ... as the Application, 0x00000000 as the MessageCount and a TimeStamp.  If I delete the MessageCount and TimeStamp, they eventually reappear.

I suspect (but have no firm proof) that this has something to do with deleting messages from the Inbox and then emptying the trash.  That is, if I received some junk mail and if I select "Delete Mail Marked as Junk in Folder" from the Inbox, without actually reading or clicking on any of the items, and then I do an Empty Trash the count of unread messages appears to go up (at least sometimes).

Comment 3

13 years ago
I've found that unchecking the "Check for new mails every x minutes" boxes on all accounts stops the problem from happening, so I now just do a manual "Get All New Messages". Does this help anyone at all?

Comment 4

13 years ago
(In reply to comment #3)
> I've found that unchecking the "Check for new mails every x minutes" boxes on
> all accounts stops the problem from happening, so I now just do a manual "Get
> All New Messages". Does this help anyone at all?

Martin, that is a workaround at best, since now you have to remember to do the manual fetches.  Looking through other bugs, I see that there are several that are the same or have a very similar description, namely, 289674, 307873, 312292 and 317940.

Further to my comment (#2), now the count has gone down to 1, but it keeps reappearing back as always.  Again the culprit appears to be deleting unread messages from the mailbox and then deleting them from trash.

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 289674 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.