Autocomplete popup doesn't close when there are no results

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: ajschult784, Assigned: ajschult784)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
bug 124674 folded alwaysOpenPopup into minResultsForPopup, but some things (Open Location, setting the home page) used the defaults and relied on the alwaysOpenPopup=false preventing the popup.  Since the default minResultsForPopup is 0, these things now always have a popup.  The default should really just be 1; location bar already overrides it.
(Assignee)

Comment 1

13 years ago
Created attachment 206356 [details] [diff] [review]
patch
Attachment #206356 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #206356 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

13 years ago
Comment on attachment 206356 [details] [diff] [review]
patch

I wonder whether we should be changing all these to use parseInt(foo, 10)?
Attachment #206356 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #206356 - Flags: superreview+
Attachment #206356 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #206356 - Flags: review+
(Assignee)

Comment 3

13 years ago
FIXED
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.