per-message option to choose HTML or plain text email

RESOLVED DUPLICATE of bug 140800

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 140800
12 years ago
12 years ago

People

(Reporter: Elliotte Rusty Harold, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051130 Firefox/1.5

I would like to have a per-message option to choose HTML or plain text email, rather than just a per-account option. 

Reproducible: Always

Steps to Reproduce:
Mostly I send plain text email, but occasionally I need to send HTML mail. I assume some other people are vice versa. It would be nice if there were somewhere an option to choose this for each message rather than having to change it for all mnessages to send just one HTML email, and then changing it back. 


Expected Results:  
I'm not sure what the user interface to this should look like. Certainly there should be a per-account default like now. The user should not have to specify every time. Perhaps as well as "New Message" there could be "New HTML message" and "New Plain Text Message" menu options? 

Or perhaps it could even be adjusted dynmaically on the fly with a button in the toolbar, though that would be more work.

Comment 1

12 years ago
The duplicate bug is for the general case of switching on-the-fly.

If you are replying, or creating a new message, from the TB client, you can 
get the results you want by holding the shift down while clicking on the New Message or Reply button.  (Also works for forwarding, if you're configured 
for Forward As Attachment.)  

There's no equivalent workaround for clicking on a mailto: or right-clicking 
a message address and selecting "Compose message to."

*** This bug has been marked as a duplicate of 140800 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.