JavaScript is supposedly enabled, and the box next to it is checked in the preferences content menu, yet web sites we've tried to use claim that Java Script is actually disabled.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: rgorlin, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

After installing Firefox 1.5, my husband was unable to check his email at jmail.umd.edu.  The page had a warning that JavaScript was disabled, so certain features of the web page wouldn't work.  Yet when we checked the content menu in Firefox Preferences, the box next to "JavaScript enabled" was checked.  I tried turning "JavaScript enabled" off and back on, then cancelling out of Firefox and checking the preferences again.  It made no difference.  Then  I tried to revert to Firefox 1.0.1, but couldn't.  We're very frustrated!  What do we do?? 

Reproducible: Always

Steps to Reproduce:
1.Go to jmail.umd.edu
2. Hit "surge mail"
3. The page you see will contain the "JavaScript not enabled" warning.  When you go on to input your name and password on that page to enter your email account, the page with the email messages doesn't load.  Instead, nothing happens and all you see is a blank screen. 

Actual Results:  
See above

Expected Results:  
According to the "JavaScript enabled" setting in the preferences, the warning should not appear and we should be able to get to the page with our email.

Comment 1

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051220 Firefox/1.6a1

I don't see a link labeled "surge mail" (step 2 in the steps to reproduce).  Instead, I see a choice between "WebMail" and "User Self Management".  Neither of those gives me a warning about JavaScript not being enabled.
(Reporter)

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> 
> After installing Firefox 1.5, my husband was unable to check his email at
> jmail.umd.edu.  The page had a warning that JavaScript was disabled, so certain
> features of the web page wouldn't work.  Yet when we checked the content menu
> in Firefox Preferences, the box next to "JavaScript enabled" was checked.  I
> tried turning "JavaScript enabled" off and back on, then cancelling out of
> Firefox and checking the preferences again.  It made no difference.  Then  I
> tried to revert to Firefox 1.0.1, but couldn't.  We're very frustrated!  What
> do we do?? 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Go to jmail.umd.edu
> 2. Hit "surge mail"
> 3. The page you see will contain the "JavaScript not enabled" warning.  When
> you go on to input your name and password on that page to enter your email
> account, the page with the email messages doesn't load.  Instead, nothing
> happens and all you see is a blank screen. 
> 
> Actual Results:  
> See above
> 
> Expected Results:  
> According to the "JavaScript enabled" setting in the preferences, the warning
> should not appear and we should be able to get to the page with our email.
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> 
> After installing Firefox 1.5, my husband was unable to check his email at
> jmail.umd.edu.  The page had a warning that JavaScript was disabled, so certain
> features of the web page wouldn't work.  Yet when we checked the content menu
> in Firefox Preferences, the box next to "JavaScript enabled" was checked.  I
> tried turning "JavaScript enabled" off and back on, then cancelling out of
> Firefox and checking the preferences again.  It made no difference.  Then  I
> tried to revert to Firefox 1.0.1, but couldn't.  We're very frustrated!  What
> do we do?? 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Go to jmail.umd.edu
> 2. Hit "surge mail"
> 3. The page you see will contain the "JavaScript not enabled" warning.  When
> you go on to input your name and password on that page to enter your email
> account, the page with the email messages doesn't load.  Instead, nothing
> happens and all you see is a blank screen. 
> 
> Actual Results:  
> See above
> 
> Expected Results:  
> According to the "JavaScript enabled" setting in the preferences, the warning
> should not appear and we should be able to get to the page with our email.
> 

(Reporter)

Comment 3

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8) Gecko/20051111 Firefox/1.5
> 
> After installing Firefox 1.5, my husband was unable to check his email at
> jmail.umd.edu.  The page had a warning that JavaScript was disabled, so certain
> features of the web page wouldn't work.  Yet when we checked the content menu
> in Firefox Preferences, the box next to "JavaScript enabled" was checked.  I
> tried turning "JavaScript enabled" off and back on, then cancelling out of
> Firefox and checking the preferences again.  It made no difference.  Then  I
> tried to revert to Firefox 1.0.1, but couldn't.  We're very frustrated!  What
> do we do?? 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Go to jmail.umd.edu
> 2. Hit "surge mail"
> 3. The page you see will contain the "JavaScript not enabled" warning.  When
> you go on to input your name and password on that page to enter your email
> account, the page with the email messages doesn't load.  Instead, nothing
> happens and all you see is a blank screen. 
> 
> Actual Results:  
> See above
> 
> Expected Results:  
> According to the "JavaScript enabled" setting in the preferences, the warning
> should not appear and we should be able to get to the page with our email.
> 
I'm sorry -- you're right -- it's the "Surgemail" page.  Choose the "webmail" option on the page and it will take you right to the page with the warning about "JavaScript not enabled." If it doesn't, then that means that what's wrong with my PowerBook isn't wrong with your Mac. 

Comment 4

12 years ago
Have the same problem at http://www.startaid.com/comment/295745/TUTORIAL---How-to-use-StartAid.html
has also occurred on other pages

Bon Echo 2.0.0.4pre 20070426
Mac OS X 10.4.9

Comment 5

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2  OSX 10,4.11 New Install Firefox/ 3.6a

Firefox Preferences Enable JavaScript ✔ Checked OK
Firefox Preferences Enable JAVA ✔ Checked OK
Firefox Add-ons  Adobe Flashplayer Not recognized after loading.

Open Web Page (HuffingtonPost) Video portions show Box/Puzzle Piece - Request to Enable Java.

Open Preferences:  Find Java "Disabled" (Not Checked)

Open Web Page (PhotoBucket)  Prompt says load latest Adobe Flash Player.

Safari Browser:  Java OK / Flask Player OK

Comment 6

9 years ago
windows trunk. using steps of comment 0 after accessing the url I get

 Browser: FAILED TEST
Note: A modern browser is needed to use the ajax interface.
  - Tested to work: IE7, Safari 3.1, Firefox 3.0, Google Chrome
  - Mostly works in : Opera 9.51, Firefox 2.0
  - Will NOT work in : various other older browsers including IE6
Note: More modern browsers such as recent Camino / Opera etc will probably work but still need further compatibility testing 


after putting in a bogus userid and password I get

You are using surgeweb with an unsupported bowser. Server policy allows this and it may work or more likely, it may result in very broken behaviour. (allow / disallow forced login with surgeweb admin setting "unsupported_browser" )

If you were expecting your browser to be supported please report this string to your support staff:
>> Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20090905 Minefield/3.7a1pre (.NET CLR 3.5.30729)

Comment 7

9 years ago
Richard E Massey
richardemassey@comcast.net
09/08/09
Confirming Bug 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4.11; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
 Model Name:	iMac
  Model Identifier:	iMac5,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.16 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache (per processor):	4 MB
  Memory:	1 GB
  Bus Speed:	667 MHz
  Boot ROM Version:	IM51.0090.B09
  SMC Version:	1.9f4
  Serial Number:	W86505NHVUV

Firefox disables Java.  Firefox Prefs De-select Java.  Firefox not recognizing Adobe Flash Player.
Situation:
Visit Web Page after Setting Perfs and Enabling Flash.  Go to:  Huffington Post to view content.
Content missing.  Notice to Enable Java. -- Download Flash.  Check Fox Perfs:  Java UNCHECKED!
Check Add-ons:  Flash DISABLED.

Happens all the time.
Very frustrating.
This is to confirm that this is happening.

Comment 8

9 years ago
Java Disabled - Plug-ins Disabled
09-23-09
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

09-23-09 4:00PM
Unresolved.
Computer Booted > Firefox Opened > Prefs Checked > Java DISABLED > Java Plug-in DISABLED > Enabled Java in Perfs. > Enabled Java Plug-in > Visited Web Site >
(Huffington Post) No Java > No Adobe Flash > Closed Firefox > Opened Safari >
Visited Site > NO Problems with Java or Plugs.  R.E.Massey richardemassey@comcast.net DeBuggers - Email me for any cooperation needed.

Comment 9

9 years ago

+ + BUMP + + 

OCT 13 2009  7:00 PM  Still NOT Resolved

Comment 10

9 years ago

November 13, 2009 8:00 EST  (Update)

U-N-R-E-S-O-L-V-E-D

If anyone want to confirm this Bug.  Contact me!
Unresolved.
Jave still being disabled by some Bug.
are you talking about JavaScript or Java? This is an important difference. The title says JS but some bugreports say something about Java...

Comment 12

9 years ago
The Preference Square for Java is de-selected.

Despite just being selected and the Preference Panel closed.

Updated

8 years ago
Version: unspecified → 1.5.0.x Branch

Comment 13

2 years ago
We no longer show options for Java or JavaScript. After more than 10 years, it seems unlikely we're going to be able to figure out what was wrong here, so marking this "works for me".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.