Lack of Mozilla's old "Window" menu is a serious usability problem on non-XP Windows

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: mozilla-bugzilla, Unassigned)

Tracking

1.5.0.x Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix?)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

My browsing sessions tend to be intensive, building up LOTS of open windows (and many tabs within those) which I wish to retain until I'm done with the research or other task at hand.

Finding a particular open window was easy in Mozilla Suite thanks to the "Window" menu.  For some reason, though, this incredibly useful feature has been removed from Firefox.  Perhaps all the developers are using window managers that make the feature less necessary.  For instance, on Windows XP (and Server 2003?), once you have a few Firefox windows open, they get collapsed on the task bar to a single item, and you can click on that for an equivalent of the Window menu.

However, I need to keep using Windows 2000 on multiple machines, and its task bar does not include this functionality.  Likewise, many Linux / UNIX window managers do not have such functionality and have a need for the Window menu. 

Mac OS X's window manager is another place where such a menu was necessary, but unfortunately the decision was made to [re-]implement the Window[s] menu for the Mac OS X platform only (see bug 204420).

Please extend the Window menu to be there on other OSes as well.  If you feel strongly that the menu shouldn't be there by default (which I would highly disagree with), then I'd be happy with having to use a preference to enable it (even a hidden one), just so long as I can get the darn thing.  I searched, BTW, and was unable to find any extensions to do this, either.

Hopefully this feature should be easy to implement, since the code is already there but turned on only for Mac OS, and you'd only have to suppress the appearance of the special Mac-OS-specific entries "Zoom Window", "Minimize Window", and "Bring All to Front" on other OSes.

Reproducible: Always

Steps to Reproduce:
(No special steps needed -- see Details.)
Actual Results:  
No Window menu except on Mac OS.

Expected Results:  
Window menu should be available on all OSes.
(Reporter)

Updated

13 years ago
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 1

13 years ago
This is also an accessibility issue, since repeatedly moving the mouse by small increments and stopping, to hover over the icons in a packed Windows-2000-or-prior task bar to get the window title tooltips requires far more coordination than activating a single Window menu.  (Likewise using Alt-Tab to cycle through all programs' open windows.)
Keywords: access

Comment 2

13 years ago
From a quick search you are the first person in 3 years to file a bug requesting this menu back. This is very likely a wontfix bug.

You may feel more comfortable using SeaMonkey. It is the community project that is working to release what would have been Mozilla Suite 1.8. http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

13 years ago
Um, no I'm not.  Like I said, bug 204420 was filed by Mac OS users wanting it back, and they got it.  I wish some consideration had been given to the users of other OSes while that was being worked on.  On a related note, bug 215621 and its dups requested that a Window[s] menu be added to Thunderbird, and again, only the Mac OS users got it.

It's true that on Mac OS X, finding one window of an app when you have a ton open is even more difficult than on Windows (2000 and prior), since all you have is Expose to find them visually.  However, just because it's even harder on Mac OS doesn't mean that it isn't a serious usability problem on pre-XP Windows and many and sundry UNIX/Linux windows managers when you have lots of windows open.

Thank you for letting me know about the SeaMonkey project -- I was not aware of that.  Unfortunately I consider the SessionSaver extension to be an absolute necessity (until such time as bug 159357 gets implemented), and it has major instability issues in Mozilla Suite (and thus, I'm sure, SeaMonkey).  I would also really prefer to be using Firefox since it is the mainstream (and thus better supported) Mozilla.org browser, and because it is a good deal speedier than Suite (which includes components I don't need).  The lack of the Window and Go menus are the only remaining lost Mozilla/Netscape/Mosaic features that cause me major pain in trying to switch to Firefox.
(Reporter)

Comment 5

13 years ago
Yes, I realize that a Windows menu is especially warranted on Mac OS X because Apple lays this down as a UI guideline, but that doesn't mean that it's not extremely useful on other platforms where it's not a hard requirement for all apps.

Indeed, on the GNOME guidelines page you link to, the "A typical menubar" example includes a "Windows" menu, and it's listed above as one of the Standard Menus.  It's not required for _all_ apps because, as they say, it only makes sense for a multiple document app (like Firefox).

Likewise in Windows land, take a look at Microsoft Office -- Word, Excel, PowerPoint, Access, etc. all have a "Window" menu, even though there's another way to get at the multiple document windows (a far less convenient way, pre-XP) via the task bar.  And this is certainly not limited to Microsoft's Office apps -- take a look at third party multiple document apps and you'll see that most have a Window menu.

Comment 6

13 years ago
(In reply to comment #2)
I too am flabbergasted that the Window menu has been removed.  Under other browsers, I use it on a routine basis to raise/lower windows, and its omission is a serious problem for me.

Firefox 0.8 ("Royal Oak"), released February 2004, actually has the Window menu intact; thus there would not have been reports of its omission until some time after that.  I don't know when the menu was removed, but in my view it was a blunder.
Microsoft IE 7 also does not have a Window menu.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

12 years ago
IE 7 is not a cross-platform app.  It's only supported on Windows XP and later, where the grouping of windows from the same app into a single popup list on the task bar (once you've opened several windows) is a reasonable substitute for the Window menu.

Firefox, on the other hand, runs on many platforms whose window managers do not include such a feature, including pre-XP versions of Windows, Mac OS X, and various flavors of UNIX / Linux.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Interesting.  Based on your logic I would agree with you, but based on the fact that this is the only complaint about this I've seen, no one's complained on irc when I've been around, I'm pushed the other way.

If it's possible to do with an extension that might be the best bet in this case.
Keywords: uiwanted

Updated

12 years ago
Keywords: access

Comment 10

12 years ago
I currently use Mozilla 1.7.X on Sun workstations running Solaris 8 and the CDE window manager.  I totally agree with Dan and Dan, that it was a mistake to remove the window menu from Firefox.  It is really needed on CDE.  I would like to migrate to Firefox, but this issue is a show-stopper for me.  I can't believe someone hasn't created an extension to add back the window menu yet.  I'll probably be forced to migrate to SeaMonkey instead.
Alex, could you have a look at this bug please?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.5.0.x Branch
>uiwanted

I believe this is best served through an extension, since the set of effected users are is limited by two things simultaneously:

1) The particular OS they are on (limitations of the window manager, Windows 2000 and some versions of Linux, Solaris, etc.).

2) The behavior of opening a lot of separate windows instead of separate tabs (which isn't an interface that we are trying to optimize for)

For the users who fit both of those attributes and are effected, this is certainly a legitimate issue, but it isn't a universal enough problem to change Firefox everywhere, or to try to detect which OS it is running on to add the menu back.
Keywords: uiwanted
(In reply to comment #12)
> I believe this is best served through an extension, since the set of effected
> users are is limited by two things simultaneously:

Means we can close it as wontfix?
Whiteboard: wontfix?
We sure can.
Status: NEW → RESOLVED
Last Resolved: 13 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.