ability to open main window after closing said window

RESOLVED WONTFIX

Status

Calendar
Sunbird Only
RESOLVED WONTFIX
13 years ago
5 years ago

People

(Reporter: Belril Dawnslayer, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Sunbird/0.3a

I noticed after accidentally closing Sunbird, that without restarting the program, it was very hard for me to open the main window again.  I know that it is possible for mozilla products to have this feature, and I ask that Sunbird get the same treatment.  

Thanks!
Belril

Reproducible: Always

Steps to Reproduce:
1. Close window (mac specific)
2. Attempt to reopen using the window menu

Actual Results:  
Nada.  No way to return to the window

Expected Results:  
I hope that there will be an option: Cmd-1 (or something like that) Calendar
I don't have a mac to test so please would you check:

Does it works with Sunbird 0.3a1+?
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/

Does it works with Firefox 1.6a1?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Does it works with Thunderbird 1.6a1?
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

I'm just curious if this is a Sunbird issue or maybe a mozilla core issue.
(Reporter)

Comment 2

13 years ago
This issue is sunbird only.  I tried the nightly build (0.3.1a+) and the problem is still not fixed.  Thanks for your help.

Comment 3

12 years ago
Confirming.  We should be able to copy the firefox code pretty much verbatim.  What we really need is someone with a mac to write the patch/test though.
http://landfill.mozilla.org/mxr-test/mozilla/source/browser/base/content/baseMenuOverlay.xul#59
http://landfill.mozilla.org/mxr-test/mozilla/source/toolkit/content/macWindowMenu.inc
http://landfill.mozilla.org/mxr-test/mozilla/source/browser/base/content/browser-menubar.inc#437
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good first bug]
Taking
Assignee: mostafah → mattwillis
Whiteboard: [good first bug]
We still need to fix this, but a workaround is to switch to a different app, then switch back via the Dock. A new Sunbird window will appear.
Blocks: 335745
Status: NEW → ASSIGNED
Target Milestone: --- → Sunbird 0.3

Comment 6

12 years ago
*** Bug 351156 has been marked as a duplicate of this bug. ***
Not going to make the 0.3 train.
Status: ASSIGNED → NEW
Target Milestone: Sunbird 0.3 → Sunbird 0.4
Nor 0.5
Assignee: lilmatt → nobody
Target Milestone: Sunbird 0.5 → Future
Target Milestone: Future → Sunbird 0.7

Updated

11 years ago
Flags: wanted-calendar0.8?
Component: General → Sunbird Only
QA Contact: general → sunbird
Target Milestone: 0.7 → ---

Comment 9

11 years ago
Setting wanted0.8- as the main Calendar developers will not devote any time to
this in the 0.8 timeframe. Patches are, of course, always welcome.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
Resolving as WONTFIX because Sunbird has been discontinued and the code has been removed from the project.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: wanted-calendar0.8-
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.