at-poke shows Mozilla as application name when running Firefox

RESOLVED FIXED

Status

()

Firefox
Disability Access
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Nian Liu(n/a in a long time), Assigned: Ginn Chen)

Tracking

({access, fixed1.8.1})

Trunk
x86
Linux
access, fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
1.run firefox
2.start at-poke

expected result:
  firefox shows in application list

actural result:
  mozilla shows in application list
(Reporter)

Comment 1

12 years ago
for patch, refer to bug230144
(Assignee)

Comment 2

12 years ago
Created attachment 207968 [details] [diff] [review]
patch
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #207968 - Flags: review?(aaronleventhal)

Updated

12 years ago
Attachment #207968 - Flags: review?(aaronleventhal) → review+
(Assignee)

Updated

12 years ago
Attachment #207968 - Flags: superreview?(roc)
I think GetBrandShortName should take an nsAString& parameter for output.

Is it really necessary to cache the result?
(Assignee)

Comment 4

12 years ago
Created attachment 210745 [details] [diff] [review]
patch v2 (addressing roc's comment)

roc's comment makes sense to me.
Attachment #210745 - Flags: superreview?(roc)
Attachment #210745 - Flags: superreview?(roc)
Attachment #210745 - Flags: superreview+
Attachment #210745 - Flags: review+
(Assignee)

Comment 5

12 years ago
Checking in nsAppRootAccessible.cpp;
/cvsroot/mozilla/accessible/src/atk/nsAppRootAccessible.cpp,v  <--  nsAppRootAccessible.cpp
new revision: 1.14; previous revision: 1.13
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: access
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Attachment #210745 - Flags: branch-1.8.1?(aaronleventhal)
(Assignee)

Updated

12 years ago
Attachment #207968 - Attachment is obsolete: true
Attachment #207968 - Flags: superreview?(roc)
Is this string designed to be presented to users or read by programs?  Should you really be using a localizable string?
(Assignee)

Comment 7

12 years ago
Present to user

Comment 8

12 years ago
I think Window/Frame/Dialog names tend to be human consumable, but the name of the top level application object (i.e., the parent of all windows/frames/dialogs of the app) tends to be a programmatic, non-localized string that typically reflects the name of the binary used to start the application.
(Assignee)

Comment 9

12 years ago
I think app name should be localizable, but program name should not.

See glib manual:

g_get_application_name ()

Gets a human-readable name for the application, as set by g_set_application_name(). This name should be localized if possible, and is intended for display to the user. Contrast with g_get_prgname(), which gets a non-localized name.

Updated

12 years ago
Summary: at-poke shows Mozila as application name when running Firefox → at-poke shows Mozilla as application name when running Firefox
Version: unspecified → Trunk

Updated

12 years ago
Attachment #210745 - Flags: approval-branch-1.8.1?(aaronleventhal) → approval-branch-1.8.1+
(Assignee)

Comment 10

12 years ago
Checking in src/atk/nsAppRootAccessible.cpp;
/cvsroot/mozilla/accessible/src/atk/nsAppRootAccessible.cpp,v  <--  nsAppRootAccessible.cpp
new revision: 1.11.26.1; previous revision: 1.11
done
Keywords: fixed1.8.1

Comment 11

12 years ago
*** Bug 309789 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.