Background image properties doesn't align to the viewport

RESOLVED DUPLICATE of bug 243751

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 243751
13 years ago
13 years ago

People

(Reporter: MeZZiN, Unassigned)

Tracking

1.5.0.x Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This is not the same as bug #243751.

The problem is in Firefox 1.5 OSX and Win2K.

The alignment is not correct for the alignment of a background image via CSS.

I have added a screen shot plus a test case.



Reproducible: Always

Steps to Reproduce:
1. make a page and add to the body a background image style align to the bottom.
2.
3.

Actual Results:  
The alignment of the image is incorect the image is align to the last element on the page and not on the lower end of the view port.

Expected Results:  
the image needs to be aligned to bottom of the viewport
(Reporter)

Comment 1

13 years ago
Created attachment 206587 [details]
test case

test case
(Reporter)

Updated

13 years ago
Summary: Background properties doesn't align to the viewport → Background image properties doesn't align to the viewport
(Reporter)

Comment 2

13 years ago
Created attachment 206588 [details]
Firefox 1.5 how it looks
(Reporter)

Comment 3

13 years ago
Created attachment 206589 [details]
How it should look in mozilla 1.7
(Reporter)

Updated

13 years ago
Severity: normal → major
Hardware: Other → All
Version: unspecified → 1.5 Branch
(In reply to comment #0)
> This is not the same as bug #243751.

Why not? This looks like exactly bug 243751.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> (In reply to comment #0)
> > This is not the same as bug #243751.
> 
> Why not? This looks like exactly bug 243751.
> 
[quote for bug #243751]
I simply forgot that the document root is html and not body. I think I should
read the html-specifications once again...
[/quote]
That bug was a user error this one is not. It is a change from version 1.07 to 1.5. This is basic CSS that should work.
Read bug 243751 comment 4 through bug 243751 comment 6. The behavior did change from 1.0.7 to 1.5; it was an intentional change to obey the CSS spec.

*** This bug has been marked as a duplicate of 243751 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.