If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

.bmp View File should detect the associated app via registry.

VERIFIED FIXED in M15

Status

CCK
CCK-Wizard
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: bmartin, Assigned: varada)

Tracking

other
x86
Windows NT

Details

(Whiteboard: [Candidacy Approved]-2 hours)

(Reporter)

Description

18 years ago
Per Bug-O-Rama review,

All View File buttons need to detect in the Windows registry, the associated 
application that allows viewing of .bmp files.

If we are planning to implement this for .bmp files, then, are we planning to 
implement this for .gif files as well???  If so, most windows systems .gif file 
association is default to MS Internet Explorer.  Netscape never gets associated 
with .gifs and the Netscape installer never makes this association.  Should we 
talk to installer team and consider setting .gif association to Netscape?
(Reporter)

Comment 1

18 years ago
*** Bug 32125 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

18 years ago
*** Bug 32126 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Severity: major → normal
Status: NEW → ASSIGNED
Whiteboard: [Candidacy Approved]-2 hours
Target Milestone: M15
(Assignee)

Comment 3

18 years ago
I have created another function called OpenViewer which would detect the default 
application for a file depending on the extension. The only problem is that gifs 
are currently opened by IE. I would therefore suggest that we use the OpenViewer 
only for bmps in the ini file and for all the rest where we want association 
with our browser we use the OpenBrowser. The OpenBrowser will launch Netscape if 
it is there in the machine else it defaults to IE.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
Reopening....

.gifs open with associated application
.html open with associated application
.txt open with associated application

Viewing .bmp files opens the browser with a "Warning: There is a possible 
security hazard here." dialog. with Open it and Save it to disk options.  .bmp 
files should open to associated application.  My machine is configured with 
MSPaint associated to .bmp files.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

18 years ago
Marking fixed.
I have changed the ini files - gifs & html open with the browser and bmp open 
with the default application.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Reopening...

After selecting View File on any .bmp in the wizard the following dialog 
appears:

Paint - D:\Program.bmp was not found

I installed CCK to D:\Program Files\Netscape\cck\
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

18 years ago
Marking fixed
Updated the inifiles to call this function
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
marking this Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.