FF loses position in page if user changes text size

RESOLVED DUPLICATE of bug 64926

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 64926
12 years ago
12 years ago

People

(Reporter: Philip Chalmers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If the user changes the text size via View->test Size or via [CTRL]+ or [CTRL]- the window scrolls - on large pages by enough to scroll out of sight the text the user was viewing.
Apparently FF tracks scrolling position in physical terms (px).

Reproducible: Always

Steps to Reproduce:
Case 1:
1. View a very long page, scroll to about half way.
2. Change text size.
3. The text which was previously visible in the window is usually scrolled off.

Case 2:
1. View a very long page.
2. Go to another page (by link, direct entry of URL, bookmark, whatever).
3. Change text size.
4. Click BACK, return to page 1.
5. The part of page 1 which was previously visible in the window is usually scrolled off.
Actual Results:  
Unwanted scrolling - see above.

Expected Results:  
The text / content which was visible before the text size change should be visible 
afterwards:
a) After a text size reduction, all text / content which was visible before the text size change should be visible afterwards.
b) There's room for debate about what should happen after a text size increase, it could be one of:
- scroll so the first line of the content is still at the top of the viewport.
- scroll so the centre of the content is centred in the viewport.
Either would be preferable to the current behaviour.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 64926 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.