Image isn't rendered in browser window and saved HTML contains style="display:none"

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Thomas Keller, Assigned: roc)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8) Gecko/20051111 Firefox/1.5

This is a very weird bug I stumbled across FF 1.5 on Linux. This can't be reproduced with FF 1.5/ FF 1.07 on Windows. What happens is that no image or embed is displayed in place where it should be displayed.

The pages are created dynamically with the Typo3 CMS.

The given link above contains the following HTML:

<div id="image"><img src="uploads/tx_itcslideshow/Marion_Caspers_Merk_01.JPG" width="113" height="145" border="0" alt="" title="" /></div>

The CSS for that looks like this:

#image {
        margin-top: 25px;
        margin-bottom: 25px;
        vertical-align: middle;
        width:560px;
        height: 345px;
        text-align: center;
        overflow: hidden;
}

#image img {
        margin-left: auto;
        margin-right: auto;
        vertical-align: middle;
}

Not only that the image is not displayed at all, if I save the HTML file the image tag looks like this (the image file isn't downloaded at all):

    <div id="image"><img style="display: none;" alt="" title="" border="0" height="145" width="113"></div>

I'll attach screens of the view as well as the saved HTML for FF 1.5 on Linux.

Reproducible: Always

Steps to Reproduce:
See above.
(Reporter)

Comment 1

12 years ago
Created attachment 206638 [details]
FF 1.0.7 on Windows... expected result
(Reporter)

Comment 2

12 years ago
Created attachment 206639 [details]
Firefox 1.5 on Linux, no display
(Reporter)

Comment 3

12 years ago
Created attachment 206640 [details]
Saved HTML from FF 1.5 Linux
Can you reproduce this when running in safe mode? (http://kb.mozillazine.org/Safe_Mode)
(Reporter)

Comment 5

12 years ago
Hrmm... three months after my original submission I have no idea how I should reproduce this bug anymore, as it works for me locally. I guess you can close it then. Still, this wasn't faked or anything, I just wonder why an style="display:none" attribute was applied on the <img> tag... is this something Mozilla does itself under any weird circumstance?
No idea. If you encounter this again in the latest version of Firefox, don't hesitate to re-open this bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.