Change mailbox format to Maildir compatible

RESOLVED DUPLICATE of bug 58308

Status

--
enhancement
RESOLVED DUPLICATE of bug 58308
13 years ago
13 years ago

People

(Reporter: jonny, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird 1.0.7

Large mailboxes are common nowadays.  This means large files for mbox-style mailboxes, which is the default for Mozilla and TB.  This style has been copied from Unix for its simplicity and eficiency.   At the first days of netscape, this also allowed me to copy entire mailboxes from Unix to NS and vice-versa.

Now the world is changing, and Unix world is migrating to Maildirs format.  It solves most problems with mbox, and is better suited for most mail server setups.

I propose we use the Maildir format internally in Mozilla and TB, for the very same reasons.

This would eliminate the need to compress mailboxes, reduce the burden on file management and reduce the chances of a mailbox crash (that still happens a lot).

I would rather like we use the very same format, to make it easier to use existing tools on the same mailboxes, but if a better feature set could be achieved by changing this format a little, I would not oppose.

Reproducible: Always

Comment 1

13 years ago
Please search before filing new bugs and include the Core bugs. This one was easy to find with "maildir".

*** This bug has been marked as a duplicate of 58308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.