crash at startup (line 131: 21513 Illegal instruction "$prog" ${1+"$@"})

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
12 years ago
8 years ago

People

(Reporter: James Rome, Unassigned)

Tracking

({crash})

1.5.0.x Branch
Other
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I installed a fresh untarred firefox 1.5 on SuSE 9.3 and deleted my old profiles:
jar@romeja:~> rm -r .mozilla
jar@romeja:~> /usr/local/firefox/firefox &
[1] 21503
jar@romeja:~> /usr/local/firefox/run-mozilla.sh: line 131: 21513 Illegal instruction     "$prog" ${1+"$@"}

This happens every time if I run it as myself. Root is able to run it OK.
(Reporter)

Comment 1

12 years ago
I should add that 
1) this used to work for me
2) It happens for Mozilla also
3) I did a chown -R jar:users .mozilla and now I get the talkback agent with every crash, so you should be able to find them. If I click details, the feedback agent dies!
4) It now happens for Thunderbird also. I am totally hosed.

Can you provide the talkback IDs?
(Reporter)

Comment 3

12 years ago
How do I find them? The window died when I tried to look at it...
Run the talkback client, which is in the extensions/talkback@mozilla.org/components subdir of your Firefox program directory. It should let you see the IDs of submitted incidents.
*** Bug 321356 has been marked as a duplicate of this bug. ***
From bug 321356 comment 1:
TB13203017H
TB13202893X
Probably a dupe of bug 296298.
Summary: line 131: 21513 Illegal instruction "$prog" ${1+"$@"} → crash at startup (line 131: 21513 Illegal instruction "$prog" ${1+"$@"})

Comment 8

12 years ago
Seeing similar problems here with an AMD K6III/450 (i586) running firefox-1.5 built from source.  N.B.: the official i686 builds have always (to date) crashed with illegal instruction errors on the above processor, which is why I've *always* had to roll my own.  Releases up through 1.0.7 have worked fine, and for what it's worth, 1.5 built and works fine on my Alpha system.

My .mozconfig is as follows (pretty standard):

. $topsrcdir/browser/config/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox_obj
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
ac_add_options --disable-tests

Kernel is 2.6.15.  Build tools, libraries, etc. meet the current build requirements.

Comment 9

12 years ago
Which version of glibc are you guys using?
(Reporter)

Comment 10

12 years ago
2.3.4-23.4

But Firefox works perfectly if I run it as root, so I really feel there is a permission problem somewhere. I tried giving myself ownership of the FireFox files which did not help.

Comment 11

12 years ago
glibc version here is 2.3.2.  Unlike James' case, things don't work any better for "root".  The crash doesn't always occur immediately upon startup, but it does always happen within the first few screens whether simply viewing web pages or attempting to edit preferences.  Best I've been able to do thus far is examine / edit all the preferences and view a small handful of pages on a web site.  Haven't noticed whether web site content makes any difference as far as graphics, plugins, etc., but I'm not going to any sites that didn't work fine with 1.0.7.  The usual case is for the crash to happen either immediately or within the first small handful of screens.

This problem "smells" similar to one I was having with the distributed.net client, which was being built with pentium-pro optimizations regardless of the x86 build platform.  In that case, the fix was to change the hard-coded "-mcpu=pentiumpro" to the correct value ("-mpcu=k6-3" in my case) for the target platform.  Evidently, some developers are/were under the impression that pentium-pro optimizations are harmless for all x86.  A detailed examination of the firefox-1.5 build output log didn't reveal that kind of thing happening as far as via compiler flags, but there might be some conditionally-compiled asm code being selected inappropriately (for some flavors of x86).

Comment 12

12 years ago
I'm having similar issues...except mine works sometimes...not in others.

I've been able to notice that firefox or thunderbird crashes after I do something (click a link, create a new message, change focus to the address bar, etc.)

However, there is no desernable pattern.

It's hard to explain away the fact that firefox and mozilla will work sometimes, while not in others.  There are times when I'll attempt to run firefox after each failed attempted and all the sudden this work again.

This bug seems random.  I've been able to confirm this bug in ubuntu as well as fedora core 4.  However, in fedora core 4, it reads as a segmentation fault at the same line (line 131).

I don't think this is a library issue.  My initial searches have shown that SCIM may be to blame.  SCIM offers a workaround:

http://www.scim-im.org/wiki/faq/gtk_gnome/why_firefox_mozilla_acrobat_reader_7_other_gtk_2_based_apps_can_not_be_installed_started

Comment 13

12 years ago
Sorry...forgot to point out that the workaround did not work for me...I do not have SCIM installed...that I know of.

Comment 14

12 years ago
I hope this additonal clue helps:

I'm able to start the profilemanager without problems.  (No crashes, segmentation faults, illegal instruction, etc.)

When I go to create a new profile, firefox walks me through creating it...all the way to the point of starting the browser.  That's when things crash.  However, I checked my profiles.ini...the new profile's entry is never make.  But the directory is created.

Hope that helps.
(Reporter)

Comment 15

12 years ago
Did not work for me either. Since it starts if I run it as root, I don't see how this can be a library issue. It must be permissions.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.