Closed Bug 321349 Opened 14 years ago Closed 14 years ago

Save page as / Web page complete fails to recursively grab CSS files

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 126309

People

(Reporter: ski, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

The styles from, e.g., http://mediamatters.org/static/stylesheets/master.css do not get saved to disk when you select save page as / web page complete:

@import url("global.css");
@import url("content.css");
@import url("sidecar.css");
@import url("buttons.css");

This results in some very strange rendering when viewing the saved version of the page.

Reproducible: Always

Steps to Reproduce:
1. Go to http://mediamatters.org (or another site with styles recursively imported, I suspect)
2. File -> Save Page as -> Web Page Complete
3. Open the saved page

Actual Results:  
Saved page is missing images and other critical style information.

Expected Results:  
Saved all the necessary styles and included images, etc. And rendered the results properly

Reproduced on windows XP with both:
Windows XP/Firefox 1.5
Windows XP/Nightly firefox build 1.6a1 as of 12/23
Mac os X/Firefox 1.5

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
My apologies, didn't find this one when I searched.

(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of 126309 ***
> 

Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.