detaching/deleting attachment of an "attachment-only" email does not work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
10 months ago

People

(Reporter: mueller8, Unassigned)

Tracking

({testcase})

testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: thunderbird-1.5rc2

If an email constits of solely an attachment, i.e. if there is no proper header,
deleting or detaching the attachment does not work: the client freezes for some time (e.g., five seconds for a 500KB attachment) and then the attachment is still present.

Reproducible: Always

Steps to Reproduce:
1. Take a message whose Content-Type is not "multipart/mixed" but e.g. 
     Content-Type: application/octet-stream; name="CardOS_PKCS11.dll"
     Content-Transfer-Encoding: base64
     Content-Disposition: attachment; filename="CardOS_PKCS11.dll"
   See full example below.
2. Click "Delete" or "Detach" on the attachment


Actual Results:  
the client freezes for some time (e.g., five seconds for a 500KB attachment) 
and then the attachment is still present.


Expected Results:  
The attachment should be gone.



From - Wed Feb 16 14:01:26 2005
X-Mozilla-Status: 0001
X-Mozilla-Status2: 10000000
From: XXX
To: YYY
Subject: attachment only
Date: Wed, 16 Feb 2005 13:57:41 +0100
MIME-Version: 1.0
Content-Type: application/octet-stream; name="test.dat"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="test.dat"

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA=
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5
QA Contact: front-end

Comment 1

11 years ago
I can confirm this on Thunderbird version 1.5.0.13 (20070809) under Mac OS X 10.4.9. I have a few examples in my mbox file, all with messages sent from Microsoft Outlook. This seems to be different from a similar problem with messages containing attachments sent from Apple Mail, which I think is the subject of Bug 362519.
(Reporter)

Updated

11 years ago
Hardware: PC → All
Version: 1.5 → 2.0
Assignee: mscott → nobody
David and jwq you are still able to reproduce your issue also with latest TB release?

In positive case could attach an email sample using above "Add an attachment" link?
Whiteboard: closeme 2009-11-13
(Reporter)

Comment 3

9 years ago
Created attachment 410983 [details]
An email consisting of an attachment only.

Hi Aureliano, the bug still exists in TB 2.0.0.23 and on TB3.0b4.
When filing the bug, I already provided a complete example,
but for your convenience I just added it as an attachment.
(Reporter)

Comment 4

9 years ago
BTW, the whole code for saving/deleting/detaching attachments seems to be pretty broken. See e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=448576 and
https://bugzilla.mozilla.org/show_bug.cgi?id=479200
OS: Linux → All
Version: 2.0 → 3.0
Confirmed here without hang

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091106 Lightning/1.0pre Shredder/3.0pre ID:20091106031950
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Whiteboard: closeme 2009-11-13
David, I think that this is dupe of bug #377087.

Feel free to reopen it if I'm wrong.  ;-)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377087
(Reporter)

Comment 7

9 years ago
No, https://bugzilla.mozilla.org/show_bug.cgi?id=377087 covers multipart/* messages. It does not cover the case of an email consisting of an attachment only (which for obvious reasons is not of Content-Type multipart/*). This case needs to be dealt with in a special way.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

9 years ago
Status: REOPENED → NEW

Comment 8

10 months ago
Tested by mailing testcase to myself. WFM on 58.0b1
Status: NEW → RESOLVED
Last Resolved: 9 years ago10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.