Too easy to lose data entered into a form.

RESOLVED DUPLICATE of bug 48333

Status

()

Firefox
Disability Access
--
enhancement
RESOLVED DUPLICATE of bug 48333
12 years ago
12 years ago

People

(Reporter: info, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I want to request a feature: confirmation upon closing a window or otherwise leaving a web page that contains form data (e.g. an e-mail message).  It's time to begin treating e-mail messages and such as DOCUMENTS, and displaying proper confirmation message boxes.

Reproducible: Always

Steps to Reproduce:
1. Open a Hotmail or Yahoo! mail "Compose Message" window.
2. Lovingly craft a long and valuable e-mail message.
3. Accidentally navigate away from the page (sometimes applies), or hit the X or close the tab (always applies).

Actual Results:  
Your e-mail message, forum post, etc. is GONE.

Expected Results:  
The software should show a Microsoft Word-type "Do you want to save changes?" message box when the following conditions are satisfied:
1. The page contains a TEXTAREA.
2. The TEXTAREA is dirty (has been changed by the user [i.e. not by an automatic JavaScript event such as onload]).
3. The user leaves/closes the page in any other way than clicking the form's 'Submit' button.

To go a step further, add a similar confirmation message box when the user clicks the form's 'Reset' button.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 48333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.