[Trunk] Search Engine's wont install from any plugin site

RESOLVED FIXED in Firefox 3 alpha1

Status

()

Firefox
Installer
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Brandon, Assigned: Gavin)

Tracking

({regression})

Trunk
Firefox 3 alpha1
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051221 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051221 Firefox/1.6a1

When I try to install a search plugin from http://mycroft.mozdev.org/ it gives me an error that reads "You will need a Mozilla based browser to install a search plugin.". I have tried to install past search install plugins with no luck.

Reproducible: Always

Steps to Reproduce:
1. Try to install any search plugin from http://mycroft.mozdev.org/
2. 
3.

Actual Results:  
Gives error "You will need a Mozilla based browser to install a search plugin."

Expected Results:  
Installs search plugin
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Check for any extensions you may have that mask the user agent string. If the problem continues, seek assistance from the MozillaZine forums (http://forums.mozillazine.org) or contact the Mycroft administrators through their mailing list.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
It dosnt help if your not using the same version. (You: Firefox/1.5)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Version: unspecified → Trunk

Comment 3

12 years ago
Confirmed with latest trunk:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051225 Firefox/1.6a1 - Build ID: 2005122505.

It works on the latest 1.8 nightly, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Search Engine's wont install from any plugin site → [Trunk] Search Engine's wont install from any plugin site
This is an installer only issue, right? Sounds like dom_sidebar.xpt needs to be added to the Windows packages-static.
regression window:
works 20051205 0627pdt
fails 20051206 0627pdt

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=20051205+0600&maxdate=20051206+0627&cvsroot=%2Fcvsroot




(In reply to comment #4)
> This is an installer only issue, right? Sounds like dom_sidebar.xpt needs to be
> added to the Windows packages-static.
> 

Nope, using zip build here

Created attachment 206826 [details] [diff] [review]
patch

Fixes the windows installer, removes old xpt from the linux installer. Not sure why the zip builds would be broken, but this is a start.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #206826 - Flags: review?(mconnor)
Depends on: 315346
Could anyone test to see if this is an issues on linux builds?

Comment 9

12 years ago
WFM on Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051226 Firefox/1.6a1 - Build ID: 2005122604.
Comment on attachment 206826 [details] [diff] [review]
patch

the zip packaging script uses the same packages manifest as the installer to ensure that the resulting installs are identical, which is why this breaks both.
Attachment #206826 - Flags: review?(mconnor) → review+
mozilla/browser/installer/unix/packages-static		1.61
mozilla/browser/installer/windows/packages-static	1.64
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
OS: All → Windows XP
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.6-
Component: Search → Installer
Target Milestone: Firefox 2 → Firefox 3 alpha1
You need to log in before you can comment on or make changes to this bug.