Status

()

--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: ian, Unassigned)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
It seems that using viewBox="" breaks <text> positioning.

TESTCASE:
   http://www.hixie.ch/tests/adhoc/svg/text/003.html

Tested on latest trunk Mac OS X. It was also broken, though in a different way, on X11 builds of early December; I haven't tested more recent X11 builds. The bug is not present on the Firefox 1.5 branch.

This bug pretty much breaks almost all the SVG images I've used recently. :-/
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Confirming this is Mac only, and still an issue in current trunk.

Comment 2

11 years ago
Seeing this do odd things in last nights build
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007113023 Minefield/3.0b2pre

... by switching fonts. Some fonts have advances that look too large in the top box, eg American Typewriter, Andale Mono, Apple Chancery, Arial. This is what I saw in previous builds.

However some fonts are now showing the A on top of the P in the top (as if the advance was 0), with the remaining advances still too large:
Arial Narrow, Baskerville, Times.

Some are worse and show all the letters lying on top of each other (Futura)

I don't see much commonality here; I'm guessing this is just overflow. In Beta 1 this version of the problem doesn't happen - the browser's default font selection was ignored in the svg, its always using a smaller sans-serif font. So it looks like improved font selection has just made this problem more obvious.
On Windows I see the letters in the upper PASS further apart than the letters in the lower PASS. This is basically bug 392233.
Depends on: 392233
The issues on Windows are fixed by the check in for bug 392233. I don't know whether the somewhat different Mac issues reported in comment 2 are fixed.
This bug is fixed on Mac, but it's not obvious which old builds I should be testing to check if it was fixed by bug 392233.
Let's just mark it WFM then.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.