UAAG: Cannot get keyboard focus to OBJECT elements with audio, video, or image

RESOLVED DUPLICATE of bug 93149

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 93149
13 years ago
12 years ago

People

(Reporter: Dan Kinnunen, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
From UAAG test suite: Can't get keyboard focus to OBJECT elements with audio, image, or video elements.

The specific failing UAAG tests are listed below.  First, here are some recommended solutions:
1. Include OBJECT elements in the tab order. 
2. Display the title attribute or content between the OBJECT begin and end tags as a tooltip or on the status line when focus is at the OBJECT element. 
3. Move keyboard focus to the OBJECT element plug-in when either Enter or F6 is pressed.  

Failing UAAG checkpoints related to this bug:

UAAG Checkpoint 2.3 – Render conditional content
- OBJECT element for audio 
  test URL:  http://www.w3.org/WAI/UA/TS/html401/cp0203/0203-OBJECT-AUDIO.html

- Test  155: OBJECT element for images
  test URL:  http://cita.rehab.uiuc.edu/wai-eval/show-test/index.php?test_id=155

- Test  156: OBJECT element for video
  test URL:  http://cita.rehab.uiuc.edu/wai-eval/show-test/index.php?test_id=156

Comment 1

13 years ago
Plugins were intentionally removed from the tab order in bug 309704, because it was impossible to tab out.  What needs to happen for it to be possible to tab out of plugins?  Once that's fixed (?), do we want users to be able to tab directly into plugins, or do we want users to be able to tab to an invisible object that, when you press enter, gives focus to the plugin?
(Assignee)

Comment 2

13 years ago
(In reply to comment #1)
> do we want users to be able to tab
> directly into plugins, or do we want users to be able to tab to an invisible
> object that, when you press enter, gives focus to the plugin?

The first option, pretty much the way IE handles it with ActiveX. We want the focusable items in the plugin to be a natural part of the tab cycle. The plugin itself is not tabbable, only the controls within it.

(Assignee)

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 93149 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.