Can't send PDF attachment

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: jlmuir, Assigned: mscott)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.12 (KHTML, like Gecko) Safari/416.13
Build Identifier: version 1.6a1 (20051228)

I am unable to send a PDF attachment using Thunderbird. If I try to send a PDF attachment to others or to myself, it sends it, but when viewed in an email client, the sent email does not display the attachment.

Sending a PDF attachment using Mozilla Mail 1.7.12 works fine.

I inspected the message source for two test emails, one sent from Thunderbird and the other from Mozilla Mail. They are attaching the PDF document differently.

Thunderbird (what does not work) attaches the document like this:

    Content-Type: multipart/mixed;
     boundary="------------080006040902050203090801"
    
    This is a multi-part message in MIME format.
    --------------080006040902050203090801
    Content-Type: text/plain; charset=ISO-8859-1; format=flowed
    Content-Transfer-Encoding: 7bit
    
    tm1
    
    --------------080006040902050203090801
    Content-Type: multipart/appledouble; x-mac-type="0"; x-mac-creator="0";
     name="colors.pdf"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
     filename="colors.pdf"
    
    <snip>base64 encoding of file was here</snip>
    --------------080006040902050203090801--

While Mozilla Mail (what does work), on the same computer, attaches the document like this:

    Content-Type: multipart/mixed;
     boundary="------------060109040505090707020207"
    
    This is a multi-part message in MIME format.
    --------------060109040505090707020207
    Content-Type: text/plain; charset=us-ascii; format=flowed
    Content-Transfer-Encoding: 7bit
    
    tm2 - sent with mozilla.
    
    --------------060109040505090707020207
    Content-Type: application/pdf; x-mac-type="0"; x-mac-creator="0";
     name="colors.pdf"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
     filename="colors.pdf"
    
    <snip>base64 encoding of file was here</snip>
    --------------060109040505090707020207--

So, Mozilla Mail attaches it with a Content-Type of "application/pdf", which is what I would like. However, Thunderbird attaches it as "multipart/appledouble".

Thanks for your great work on Thunderbird!


Reproducible: Always

Steps to Reproduce:
1. Click Write button.
2. Enter your own email address in the To field.
3. Enter a subject of "test message 1".
4. Enter a body of "test message 1".
5. Click Attach button.
6. Choose small PDF document.
7. Click Send button.
8. View sent email in Inbox.

Actual Results:  
The email is delivered, but when viewed, no attachment is listed.


Expected Results:  
The email is delivered, and when viewed, it lists the attached file in the Attachments box at the bottom of the email.


This problem also exists in Thunderbird 1.0.7 for Mac OS X.
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

13 years ago
Created attachment 207001 [details]
The test PDF document I used.

Comment 2

12 years ago
I'm on a Mac 10.4.7 with TB 1.5.0.4. I took your test document (attachment.cgi) and, after changing the suffix to pdf sent it as an attachment to myself. I received it, was able to save it and open it with no problem.

Note, I send out dozens of pdf files every day using TB to people on Macs, Linux and Windows with no problem.
(Reporter)

Comment 3

12 years ago
I just tried with the same version of Mac OS X and TB as you. It worked for me too. So it would seem the problem has been fixed.

Thanks!

Comment 4

12 years ago
I am using Thunderbird version 1.5.0.7 (20060909) on MAC OS X 10.4.8

Everything was working fine, until for no reason I couldn't send pdf anymore.
Since then, I have exactly the same problem described here.

It's really painfull.

I have no idea what's going on.. I looked in any options menu can't see what could fix the problem. I also re-installed the last version of Thunderbird...

Please, let me know you have an idea..


Paul
QA Contact: message-compose

Comment 5

11 years ago
Paul is it still a problem? with thunderbird 2?

Comment 6

11 years ago
Given comment #3, the lack of response to comment #5, and my own testing, marking WFM.  Please reopen if you're still seeing this bug on a trunk nightly build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.