If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox crashes when loading web page

RESOLVED DUPLICATE of bug 40931

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 40931
12 years ago
12 years ago

People

(Reporter: Ville Tervo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

Firefox craches when I try to load "http://www.bof.fi/fin/0_new/0.1_valuuttak/". I tried with reported version and 1.5 release, 1.6 snapshot 28.12.2005, and mozilla snapshot Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050702 28.12.2005. I was entering webpage from google "valuuttakurssit" search. The first hit should be the url mentioned in report.

Reproducible: Always

Steps to Reproduce:
1. Start firefox or mozilla in linux pc
2. Go to http://www.bof.fi/fin/0_new/0.1_valuuttak/

Actual Results:  
Firefox crashes with following error message
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 9960 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)



Expected Results:  
Webpage is rendered

I'm using debian testing. Mac version 1.5 works as expected.

Comment 1

12 years ago
Works for me in 1.0.7/1.5/1.6a1 on winxp. Can you test an official Mozilla build with talkback installed and submit the talkback incident when|if it crashes?
(Reporter)

Comment 2

12 years ago
I tested with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920. Talkback didn't pop up after crach. Should it work without configuration? I got following error message.

Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 40744 error_code 11 request_code 53 minor_code 0

Comment 3

12 years ago
A frame contains an illegal character, I guess this can be duped to some other Linux bug.

http://www.bof.fi/fin/0_new/0.1_valuuttak/fix-fin.stm
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.bof.fi%2Ffin%2F0_new%2F0.1_valuuttak%2Ffix-fin.stm

13. Error  Line 181 column 43: non SGML character number 154.

<TD BGCOLOR="#F0FAFE" ALIGN="left"><FONT >T&#65533;&#65533;ekki</FONT></TD>

You have used an illegal character in your text. HTML uses the standard UNICODE Consortium character repertoire, and it leaves undefined (among others) 65 character codes (0 to 31 inclusive and 127 to 159 inclusive) that are sometimes used for typographical quote marks and similar in proprietary character sets. The validator has found one of these undefined characters in your document.

Comment 4

12 years ago
I get similar crashes a couple of times a day, but have yet to notice a correlation with a particular site. Here's a C&P of the lastest one:

 The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 19045088 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I'm on FreeBSD 6.0-RELEASE using Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8) Gecko/20051228 Firefox/1.5 built from ports.

Comment 5

12 years ago
This looks a lot like #40931 to my untutored eye.
Depends on: 40931

*** This bug has been marked as a duplicate of 40931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.