Firefox eats up most of the memory

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: thomas, Unassigned)

Tracking

({memory-leak})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

I used FF for about 1.5 hours to browse graphic intensive websites and found out that my machine gets slower and slower.
A look into the task manager showed me that FF is eating up about 625MB of a 1GB memory machine. This is not acceptable. FF should partially empty its memory at a specific point. Actually it does empty something, but then only for about 20MB.

Reproducible: Always

Steps to Reproduce:
1. Browse graphics intensive websites for a while
2.
3.

Actual Results:  
firefox.exe's memory usage should increase all the time. Sometimes it drops down, but then only for about 20-25MB, not more. 

Expected Results:  
Machine should get slower and slower.
(Reporter)

Comment 1

13 years ago
Created attachment 207033 [details]
Screenshot of task manager

This partial screen shot should show how much memory FF can use. The machine has 1GB. Since FF is already more than 600MB and some background processes are also running, the system start to swap and swap. This causes a lot of I/O traffic which additionally slows down the machine.
(Q1) How about "real memory usage" of Firefox when "virtual memory(storage) usage" is very large?
(Q2) Does your problem occur even when new profile(no extention)?
(Q3) Try nexts when large(200MB to 400MB) "virtual memory usage" of Firefox.
      (1) Open a new window of your HOME PAGE only tab
      (2) Close old window
      (3) Continue to work in the new window(access Web pages)
     Does "Virtual memory usage" and "Real momery usage" continue to grow?
     Does "Virtual memory usage" easily exceed 600MB?
(Q4) What will happen when "bfcache" is disabled?
     Set nexts thru about:config if exists in about:config display.
     (with 'history' in filter field.)
     (a) browser.sessionhistory.max_viewers       = 0 (probably -1 is set)
     (b) browser.sessionhistory.max_total_viewers = 0 (probably -1 is set)
     Does "Virtual memory usage" grow rapidly?

Comment 3

13 years ago
Reporter, are you using Adblock ? In my experience, removing that exension (not just disabling, really removing), cured my memory problems. Adblock Plus is a good replacement, and doesn't show this error. Your mileage might vary though.
(Reporter)

Comment 4

13 years ago
Yes, I use AdBlock, never heard about AdBlock Plus. I'll give it a try then.

Comment 5

13 years ago
Thomas Klinger, please report back here if the memory usage got better after uninstalling AdBlock
See Bug 321661(probably DUP of Bug 306862) for problem when bfcache is enabled.
See also meta bug 320915 for other "eating up of memory" reports of Firefox 1.5. 
(Reporter)

Comment 7

13 years ago
The problem is solved.

I did:
- set browser.sessionhistory.max_total_viewers = 0 
- installed AdBlock Plus instead of AdBlock

The situation now is that every time I close a tab with a large image the memory of it is freed.

Thanks for the help!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 8

13 years ago
Nothing was fixed here, reopening
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 9

13 years ago
I have been reading through the bug lists and variations of this are RAMPANT.  I wanted to add a quick test case to reproduce the issue:

1.  Activate Task Manager and select the performance tab.
2.  Note the amount of 'Available' memory in the 'Physical Memory (K) pane.  Alternatively and more specifically, note the used memory of 'firefox.exe' on the 'Processes' tab.
3.  Open an instance of Firefox.  Note the available memory.  Leave this one alone.
4.  Open another instance of Firefox.  Note the available memory.
5.  Open another instance of Firefox.  Note the available memory.
6.  Close the last opened instance.  NOTE that the memory used by the process and by the operating system DOES NOT decrease.
7.  Open some more; watch the memory use climb.  Close some more; watch the memory usage stay the same.
8.  Memory is completely release when ALL instances of Firefox are closed.

It SEEMS that saving/downloading a .jpg here and there, or possibly hitting pages with javascript, rapidly accellerates the process of memory consumption.

Comment 10

13 years ago
(In reply to comment #8)
> Nothing was fixed here, reopening

Can you give a specific set of steps to reproduce this problem? I've tried browsing "graphic intensive websites" and can't see the problem.

Updated

13 years ago
Keywords: mlk
(Reporter)

Comment 11

13 years ago
Well, different to specify this. I just browsed websites which provide lots of images, I mean really image galleries. A lot of them I save to my local disk. After a while the browser gets slower and slower and you also hear/see the activity of the harddisk, too. First I thought it could be the cache, so I emptied it, no effect. Well, I then continued browsing and saving images and that's the point where I got to.

Comment 12

13 years ago
(In reply to comment #11)
> Well, different to specify this.

Now I'm *really* confused. I thought you said "The problem is solved." Are you still having the problem? If so, can you give a *specific* set of steps to reproduce the problem? Which "really large image galleries" cause the problem? How many images do you need to see and save before you see a problem? Are there any other symptoms besides slowness? Is this really a memory issue?
(Reporter)

Comment 13

13 years ago
Well, actually, the case with eating up the memory is mostly solved I think, I set the case already to closed. Why it was reopened I don't know.

The current situation is that the memory issue seems to be fixed from my point of view. I only have the problem that the browser now very often crashes, but after very different scenarios.

From my point of view you could close it.

Comment 14

13 years ago
I'll try a suggestion I saw on Slashdot yesterday:

Steps to reproduce:
1. Go to http://www.the-underdogs.org/
2. Click on the Hall of Belated Fame link
3. Save the top left image on each page
4. Wait until the page is fully loaded, then click the Next link and repeat steps 3-4
5. After viewing all 31 Hall of Belated Fame pages, click on Random Link and repeat step 5

Here's the memory info for each ten pages:
Pages  Mem Usage  VM Size  Mem Cache Storage in Use
10     49 MB      40 MB    16 MB
20     61 MB      51 MB    29 MB
30     70 MB      60 MB    32 MB
40     64 MB      55 MB    32 MB
At this point, I closed Firefox and the leak gauge indicates 0 leak objects.

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 with a new profile on a computer with 1 GB of RAM. It looks to me like the extra memory usage at first is due to the caches filling up, then memory stabilizes. I can't reproduce any memory problem, and unless someone posts a set of instructions that does, we should close this bug as WFM.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 15

13 years ago
Note that Adblock v5 d3 * nightly 42 (since Jan the 16th) seems to have fixed the memory issue. I went back from Adblock Plus to Adblock, and I haven't had memory problems since.

Comment 16

13 years ago
I have not seem the same results using that version of Adblock.  Memory leakage is still rapid and vast using multiple browser windows and multiple downloads of files and images.

TW

Comment 17

13 years ago
(In reply to comment #16)
> I have not seem the same results using that version of Adblock.  Memory leakage
> is still rapid and vast using multiple browser windows and multiple downloads
> of files and images.

Steps to reproduce? Possibly you're seeing bug 213534?

Comment 18

13 years ago
Clearing the blocking on 320915
No longer blocks: 320915
You need to log in before you can comment on or make changes to this bug.