Undo: completely unpredictable when it will enable or work.

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
11 years ago

People

(Reporter: laurel, Assigned: naving)

Tracking

({platform-parity})

Trunk
PowerPC
All
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][nsbeta2-] relnote-user)

(Reporter)

Description

19 years ago
Using 2000-03-15-18nb1b commercial build mac OS 9.0

This may wind up being a duplicate of the many Undo bugs already out there, but
the Mac's Undo seems to be behaving differently than other platforms.  It is
extremely unpredictable as to whether or not or when Undo will be enabled for an
operation  (I focused mostly on delete, but Move didn't behave a whole lot
better the couple times I tried) and whether it will really work when selected.
The only thing that has been consistent in my experience is that it will never
enable on the first delete.

Here's a couple examples I've seen (both IMAP and POP):
Scenario #1:
1.  Date sort. Select top message in inbox thread pane. Delete message. Check
Edit|Undo.  NOT ENABLED.
2.  Delete another couple individual messages in the inbox.  Check Edit|Undo.
NOT ENABLED.
3.  Select/open Trash folder where messages were send upon deletion.  Check
Edit/Undo.  NOT ENABLED.
4.  Go back to inbox. Check Edit/Undo. NOT ENABLED.
5.  Still in inbox, delete another message.  Check Edit/Undo. UNDO ENABLED. Try
it. It works.

Scenario #2:
1.  Open inbox, select a message and delete it. Check Edit|Undo. NOT ENABLED.
2.  Go to the trash folder where deleted message was sent. Select the (deleted)
message in the trash folder. Check Edit|Undo.  UNDO ENABLED. Try it. It doesn't
work.

Scenario #3:
1.  Open inbox, select a message and delete it. Check Edit|Undo. NOT ENABLED>
2.  Switch to another folder and delete another  message or two. Check
Edit|Undo.  UNDO ENABLED. Try it. It works to bring back the most recently
delete message.

Combine with Move or Copy and you really get some unpredictable situations. 
General kind of bug, or so it seems. Many combinations to try.  All appear to
work very much differently (better) on linux, windows.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M16

Comment 1

19 years ago
This is pretty serious and it's platform parity.  Marking PP, nsbeta2.
Keywords: nsbeta2, pp

Comment 2

19 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 3

19 years ago
Putting on [nsbeta2+] radar for beta2 fix.   The area we care about for beta2 is 
undoing Delete.
Whiteboard: [nsbeta2+]

Comment 4

19 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Marking verified.
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
reopening for Laurel to verify.
This is an area which has had problems in the past so the reporter/qa contact 
needs to verify this bug.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 7

19 years ago
.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

19 years ago
This is still pretty much the same as it was before. Reopening.
Most notable is that after deleting a message or two, the Undo doesn't enable
until you switch to another folder (then using Undo will undo the delete from
the previous folder).  If you delete in the folder you're in (after switching
folders once), it's enabled, but after a couple deletions it won't undo anymore.

Current behavior applies on both IMAP and POP.
Using mac OS 9.0 with july 11 commercial build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

19 years ago
Hmm well jefft is gone on sabbatical so we'll need to re-assign this beast. I
wonder though given the new criteria for nsbeta2'ness....would we pull a beta
off the wire for this bug?

This may no longer be a nsbeta2+ bug due to where we are in the
cycle....lisa/laurel, what do ya'll think?

Comment 10

19 years ago
add myself to CC - I will a look at this tomorrow.
(Reporter)

Comment 11

19 years ago
As far as beta2 goes, I don't know that we should hold for this problem. It does
make Undo kind of hard to figure out on Mac, but we've postponed so many other
items, why not undo?

Comment 12

19 years ago
ugh, I didn't realize it was mac-only!
Yeah, I vote for postponing this, esp since
1) my mac expertise is basically zero.
2) it's not unpredictably reproducable
3) Our Mac expert, JF could be spending his time on more important stuff

requesting re-evaluation by PDT
Whiteboard: [nsbeta2+]

Comment 13

19 years ago
I'll make it a minus. 
Whiteboard: [nsbeta2-]

Comment 14

19 years ago
nominate for b3 triage since Undo should work at some time :-)
Keywords: b3mail
Target Milestone: M17 → M18

Comment 15

19 years ago
Adding nsbeta3 to b3mail bugs.
Keywords: nsbeta3

Comment 16

19 years ago
Removing b3mail keyword (these bugs have been promoted now.)
Keywords: b3mail
(Reporter)

Updated

19 years ago
Keywords: relnote2

Updated

19 years ago
Keywords: mail2

Comment 17

19 years ago
- per mail triage for now
We'll do an assessment of where Undo stands (ie. how broken it is) and decide if 
we need to remove this feature rather than have it not working as expected for 
people.
Whiteboard: [nsbeta2-] → [nsbeta3-][nsbeta2-]
(Reporter)

Updated

19 years ago
Keywords: relnote3, relnoteRTM

Updated

19 years ago
Keywords: mail2

Comment 18

19 years ago
sorry for the extra email. Removing mail2 keyword.
lchiang: I take it Undo made it into the final release? :-)

There will probably be a general Undo release note, and this seems a good place 
for it...

Gerv
Keywords: relnote2, relnote3
OS: All
Whiteboard: [nsbeta3-][nsbeta2-] → [nsbeta3-][nsbeta2-] relnote-user

Comment 20

19 years ago
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: REOPENED → NEW

Updated

18 years ago
Target Milestone: M18 → ---
(Assignee)

Comment 21

18 years ago
is this still true ? I am sure of some improvements here. 
(Reporter)

Comment 22

18 years ago
It seems it has improved. I just tried a few scenarios with july13 commercial
branch build on Mac OS 9.0 and looks to be okay.  I'll mark this one worksforme
and when specific situations are encountered they can be logged as new separate
reports.
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 23

18 years ago
Marking verified. When new situations are encountered they can be logged
separately .
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.