firefox locked up, had to create new profile, lost my bookmarks because of this

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: cul8rg8r, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

the summary really says it all.. Firefox locked up on a site, which was the first time it happened. It was causing other things to lock up when trying to go to them. I closed firefox, and then tried to reopen. the 'default' profile was 'active' and so couldn't use it, so had to create a new one. Now that I've done it, I cannot access the previous bookmarks on the profile.
When going into the program files\mozilla firefox\......... I cannot find anything about profiles or bookmarks there to try and find them. What do I do?

Reproducible: Didn't try

Steps to Reproduce:
1. find a page that just continues 'searching' without the results coming up.
2. close firefox
3. try opening again




annoyed that I lost all my saved bookmarks. I would love to know how to get them back if possible... or reload the initial 'default' profile.

Comment 1

13 years ago
Simple.

Run firefox using -profilemanager in start menu / run

After this, select the older profile.

-> INVALID ?

Comment 2

13 years ago
(In reply to comment #0)
> Firefox locked up on a site, which was the
> first time it happened. It was causing other things to lock up when trying to
> go to them. I closed firefox, and then tried to reopen. the 'default' profile
> was 'active' and so couldn't use it, so had to create a new one. Now that I've
> done it, I cannot access the previous bookmarks on the profile.

> annoyed that I lost all my saved bookmarks. I would love to know how to get
> them back if possible... or reload the initial 'default' profile.
> 

Search for 'parent.lock' (without the quotes). This zero-byte-sized file in your profile tells your profile is in use. Normally it gets deleted when the browser shuts down. As it didn't get deleted when Firefox crashed, you can't use the profile because it seems to be use. Delete parent.lock and you should be able to select your profile.
Your bookmarks are not lost, they are in a file named bookmarks.html in the profile. 

You can ask and get more answers in the support forum
http://forums.mozillazine.org/viewforum.php?f=38

I'm resolving the bug as invalid, as it is a support question not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.