Ask me before clearing private data is grayed/greyed/disabled

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Nedim Celik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Ask me before clearing private data is grayed/greyed/disabled.

I have installed different versions of 1.6 and 1.5 and they all have the same problem. A reinstall of the browser does not solve the problem. I assume something got set by some beta-version at some point and now this can not be changed through menues.

Reproducible: Always

Steps to Reproduce:
1.Go to Menu -> Options -> Privacy
2.Clear private data tool
3.

Actual Results:  
"Ask me before clearing private data" checkbox is greyed out.

Expected Results:  
"Ask me before clearing private data" checkbox available.

Many versions of alpha and beta Firefox have been installed on the system before.

Comment 1

12 years ago
And in Tools -> Clear Private Data ? (the other is only for setting the option)

Comment 2

12 years ago
"Ask me before clearing private data" is intentionally disabled (always checked) if "saved passwords" is checked.
(Reporter)

Comment 3

12 years ago
Tools -> Clear Private Data brings me to the same menu. The bottom checkbox "Ask me before clearing..." is grayed out.

Comment 4

12 years ago
Is "saved passwords" checked, and does unchecking it fix the problem?
(Reporter)

Comment 5

12 years ago
Yes! That is it!

I understand the thought behind this, but IMHO, this is somebody doing the thinking for me. I don't think this policy (when deleting passwords you MUST ask for deletion every time) is a good policy. Give me freedom to decide.

I extensively googled this problem and did not find any resolution. I am not saying it's not documented, just I was not able to find it. If I fell into this trap other people might as well.

Thanks again for helping me resolve this (selfinflicted?) problem!

Comment 6

12 years ago
Nedim, feel free to create an extension or edit the code yourself if this is what you want to accomplish, but this is done purposefully and for good reasons IMO.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 7

12 years ago
Created attachment 208746 [details]
Dialog showing the greyed out option.

Once this option box gets greyed out, there's no way to enable it again.

Comment 8

12 years ago
I'd agree with Nedim: this is a bad idea.
I absolutely do not want under any circumstances for my browser to store my passwords on the computer.  This is a huge security threat.

I also don't want the browser constantly nagging me every time I quit (or worse, having firefox clear nothing because I shut down the computer without manually closing firefox and clicking the nag box).

If I were to edit the code and remove this "feature", what are the chances that it will make it into the main code?

Comment 9

12 years ago
kstenerud@hotmail.com: As a workaround, you can disable password manager (options > privacy > passwords > uncheck "remember passwords"), then uncheck "saved passwords" in the Clear Private Data dialog.
You need to log in before you can comment on or make changes to this bug.