Child window with features specified unable to render flash in iframe

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: jeff, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla Firefox 1.0, Copyright (c) 2004 mozilla.org

I am trying to open a child window via javascript that contains an iframe with it's source pointing to a flash file. (i.e. <iframe src="sample.swf"></iframe>).

Using javascript's window.open() function, if one or more features are specified in the third parameter (i.e.  window.open("child.html","","toolbar=no"), the child window is unable to render/load it's flash application. If no featrues are specified (i.e.  window.open("child.html","",""), the child window renders/loads it's flash application just fine.

Reproducible: Always

Steps to Reproduce:
1. Create parent html page that opens child window on load. Note the one or more features (toolbar=no) specified in the window.open() function:

<html>
<head>
<script language="javascript">
function doOnLoad(){
  window.open("child.html", "", "toolbar=no");
}
</script>
</head>
<body onload="doOnLoad()"></body>
</html>

2. Create child html page that contains an iframe with it's source pointing to a flash file:

<html>
<head>
</head>
<body>
 <iframe src="sample.swf"></iframe>
</body>
</html>

3. Open the parent html file in the browser. 

Actual Results:  
When the child window opens, the iframe is unable to render the flash application.

Expected Results:  
The iframe should load and render the flash application.

Linux Distribution: Linux 2.6.9-5.EL #1 Wed Jan 5 19:22:18 EST 2005 i686 i686 i386 GNU/Linux

Flash plugin: Flash Player 7 for Mozilla 1.2 (Linux x86 distribution)
Can you provide a link to a webpage which demonstrates this, please?
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.0 Branch

Comment 3

11 years ago
No response, major rendering engine changes likely to affect this → resolving WORKSFORME.
If you can reproduce this bug with the latest Firefox 3 build, please reopen.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.