Closed Bug 321974 Opened 17 years ago Closed 17 years ago

scroll wheel failure when opening website with JAVA applet included

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 309344

People

(Reporter: rotis, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When opening a website that includes a Java applet, immediately the scroll wheel support for the used mouse fails and one can only scoll using the scrollbars and scroll arrows. If such a Java applet site opens in a tab, it happens too, and after closing the "Java infected" tab the scoll wheel support continues to fail. Restart of Firefox enables scroll wheel support again, until you open another site with an Java applet.

Restart can prevented by closing all windows and reopen a new. Now scroll wheel support ist again active BUT it is a problem opening a Firefox window after a scroll wheel failure. Keyboard shortcuts do not work (Apple/Cmd-N) and clicking the mouse in the Firefox menus show no popping up menus. Workaround: Clicking the Firefox icon in the Dock opens a new window.

Used hardware: iBook 1,4 GHz 14 inch screen, Apple MightyMouse
OS: Mac OS X 10.4.3

Reproducible: Always

Steps to Reproduce:
1. Open website with Java applet, and the bug shows up (scoll wheel fails)

Actual Results:  
A few seconds ago this bug appeared again. Scroll wheel failed. After sending this bug report I have to reopen a new Firefox window.

Expected Results:  
Java applets should have no effect or shut down mouse wheel support.

It is my personal conclusion that JAVA applets are the cause of failure. I'm pretty sure.

*** This bug has been marked as a duplicate of 309344 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.