save an image, X for closing tabs disappears

RESOLVED DUPLICATE of bug 305970

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 305970
12 years ago
12 years ago

People

(Reporter: brian curtin, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

at random, when trying to save an image, the menu you get when right clicking stays visible and the actual file saving dialog is only viewable behind that layer created by the right click menu. firefox then slows itself down and you cant do anything for a few seconds, and every time that happens a blank grey bar the same size as the one containing File/Edit/etc is inserted above File and it contains nothing and does nothing. sometimes, roughly 1/3 of the time the above happens, the add to it that all tabs (especially if multiple are open) resize themself to the default size even if say 10 tabs are open (pushing some tabs off of the window). at the same time, the red X button is removed and the only way out is to close and restart firefox

i have tried to delete my profile, as i was told it may have been corrupted somehow, but it keeps happening at random when saving a picture.

Reproducible: Sometimes

Steps to Reproduce:
1. save a picture
2. roll the dice and see if you are a winner. one thing about this step is that upon opening firefox, if the error doesnt happen in roughly the first 4-5 pictures you might try to save, it isnt going to happen (or it hasnt happened for me after saving a few).
Actual Results:  
nothing when i just did it now, but its a random issue that i havent seen any correlation between occurences. i have opened up firefox via a terminal and when i get this error, there is nothing showing in the terminal so i dont really have any solid info other than my probably bad wording of the situation.

Expected Results:  
saved a picture and not messed up the tabs and cause all current pages to be lost (not a huge deal) but can only be fixed by restarting firefox. until it is restarted, it is basically useless.

configuration: ubuntu linux 2.6.12-10-686-smp kernel
using: google toolbar, web developer extension (WD stays hidden until i want it)
(Reporter)

Comment 1

12 years ago
i was able to recreate these events not too long after submitting this bug report, so i took a screenshot to show you what i meant. you can see the extra grey space above the File menus, save dialog stays behind the right click menu, and the red X to close tabs is gone. as far as the recreation went: i was just saving a picture, and i had not been on that site (myspace.com) since the last reinstall of my OS so i havent had any prior experience with trouble on that site.

sorry for the large size: http://briancurtin.com/images/bug_picture.png
Blank space on top: Bug 319835, Bug 319452, Bug 311438.
Weird Save Image As behaviour: Bug 305970 
Reporter, can you try out if the problem still exists in the latest nightly?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 305970 ***
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5 Branch
You need to log in before you can comment on or make changes to this bug.