All users were logged out of Bugzilla on October 13th, 2018

popup lists and context menus interfere with dashboard

RESOLVED DUPLICATE of bug 438789

Status

()

RESOLVED DUPLICATE of bug 438789
13 years ago
10 years ago

People

(Reporter: logan.d.shaw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051231 Firefox/1.6a1

Popup lists and context menus from anywhere in Firefox conflict with
Dashboard.

If you hit F12 to bring up Dashboard while a Firefox popup list
or context menu is active, the Firefox popup list or context menu
will stay active and even obscure any Dashboard widgets whose area
intersects with its area.  Also, the popup list does not grey out
like everything else on the screen does.

Reproducible: Always

Steps to Reproduce:
1.  Click on something that brings up a popup menu.  For example, click
    on the isosceles triangle (popup-list trigger) next to the left
    history arrow.  Or bring up the list of fonts next to
    "Default Font:" in Preferences.
2.  Hit F12 to bring up Dashboard.
3.  You should see the popup list on TOP of all the Dashboard stuff.
Actual Results:  
Popup list appears on top of all the Dashboard stuff, obscuring any
Dashboard widgets whose area intersects the popup list's area.
Also, the popup list isn't greyed out like everything else is when
Dashboard comes up.

Expected Results:  
Popup list should be greyed out and should remain behind Dashboard
widgets.  Or, popup list should be dismissed before Dashboard
comes up.  (The latter is what iTunes and Safari does.  You can
get a popup list in iTunes easily by going to Party Shuffle mode,
then looking at the bottom.  You can get a context menu in iTunes
by doing control-click on a song in the list.)

For extra added fun, bring up a context menu from within Firefox,
hit F12 to bring up Dashboard, then click on the "(+)" thingy
at the bottom left of the screen to see the list of widgets.
When you do this, the context menu will move upwards along with
everything else, but the mouse pointer is tracked as if the
context menu hasn't moved.

Comment 1

13 years ago
This occurs in Thunderbird too so it's probably a core issue. I am running Mac OS X 10.4 on an Intel processor.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 438789
You need to log in before you can comment on or make changes to this bug.