Closed Bug 322040 Opened 15 years ago Closed 15 years ago

Incorrect layout of html href links with ltr text description with a punctuation mark at the end.

Categories

(Core :: Layout, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 178991

People

(Reporter: omry_y, Unassigned)

References

()

Details

(Keywords: rtl)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

in the example (http://firefang.net/~omry/t.html), there are links to two different sites.
mozilla only allow access to the first site via both links.
this bug was reproduced in firefox 1.07, latest firefox from nightly (1.6 beta), and latest mozilla from nightly (mozilla-i686-pc-linux-gnu.tar.gz).

Reproducible: Always

Steps to Reproduce:
1.http://firefang.net/~omry/t.html
2. mouse over the two links, see that there is only one target site.
3. check other browsers, where it works fine.
Flags: testcase+
This is the test case html.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>Gregarius</title>
	<style type="text/css">
	    h4 { display: inline; }
	</style>
</head>

<body>
<h4>
<a href="http://google.com" > &#1490;&#1512;&#1490;&#1512;&#1503;</a>

<a href="http://firefang.net/blog/?p=44">&nbsp;&raquo;&nbsp;	&#1502;&#1495;&#1513;&#1489;&#1493;&#1514;, &#1502;&#1495;&#1513;&#1489;&#1497;&#1501;, &#1493;&#1513;&#1488;&#1512; &#1491;&#1489;&#1512;&#1497; &#1489;&#1500;&#1506;.</a>
</h4>
</body>
</html>
The document is declaring English as it's language and the text direction isn't set to 'rtl'. The following is vaild and will work properly:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//HE" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="he" dir="rtl">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"  />
	<title>Gregarius</title>
	<style type="text/css">
	    h4 { display: inline; }
	</style>
</head>

<body>
<h4>
<a href="http://google.com" > &#1490;&#1512;&#1490;&#1512;&#1503;</a>

<a href="http://firefang.net/blog/?p=44">&nbsp;&raquo;&nbsp;	&#1502;&#1495;&#1513;&#1489;&#1493;&#1514;, &#1502;&#1495;&#1513;&#1489;&#1497;&#1501;, &#1493;&#1513;&#1488;&#1512; &#1491;&#1489;&#1512;&#1497; &#1489;&#1500;&#1506;.</a>
</h4>
</body>
</html>
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
Flags: testcase+ → testcase-
Ok..
this is a problem, as tihs code is from a web based n rss feed agregator, which can't be sure what is the language of its input, and will possibly need to handle mixed languages.
any suggestions?
Thanks.
Assignee: general → nobody
Component: General → Layout
Product: Mozilla Application Suite → Core
QA Contact: general → layout
Version: unspecified → Trunk
why is it invalid that clicking on an <a> element does not go to its URL?

(fwiw, as that document is HTML instead of XHTML, it does not declare english as its language. that xml: stuff is ignored)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Attached file testcase
the issue is the "." at the "end" of the line.  gecko seems to decide on the fly which parts are rtl vs. ltr.  The "." is ltr and goes at the end of the line but is part of the second link, so the second link spans the first one.

Specifying rtl explicitly "fixes" it.
confirmed with CVS trunk build
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Incorrect rendering of html href links → Incorrect layout of html href links with ltr text description with a punctuation mark at the end.

*** This bug has been marked as a duplicate of 178991 ***
Status: NEW → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.