should scroll the result into view on evaluating an expression

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: mikel, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
When I try in some JavaScript code in the JavaScript console, I can only see the result by scrolling down.

The console should work like a traditional UNIX/DOS console where the screen is automatically scrolled to see the output of the command.
There is an option to change the sort order in the context-menu.

Updated

13 years ago
Summary: should automatically scroll on evaluating an expression → should automatically scroll to bottom on evaluating an expression

Comment 2

13 years ago
See also bug 106696. This one is a bit different, because it only asks to scroll the results of an expression evaluation into view.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: should automatically scroll to bottom on evaluating an expression → should scroll the result into view on evaluating an expression
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.