Regression: Attachment pane of standalone message window too big

VERIFIED DUPLICATE of bug 223340

Status

Thunderbird
Mail Window Front End
VERIFIED DUPLICATE of bug 223340
12 years ago
12 years ago

People

(Reporter: Shaddy Baddah, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla Thunderbird version 1.5 (20051201)

I am subscribed to a digest mailing list. I receive a single email containing up to 30 individual email attachments.

When I double click on an attachment, this will open a new standalone message window with the contents of the attached email. In this standalone message window, the attachment list of the "original" digest email is visible. In my opinion, it is debatable whether this in itself is a bug or not.

However, the bug I am reporting is that in this window, the attachment list pane grows to take up an extremely large portion of the message window. Too large, as it results in a very tiny visible area for the text of the email. This requires scrolling. There is no way to adjust the size of the pane either, which perhaps could be considered another bug.

This is also a regression from the 1.0 series of Thunderbird. In that series, the size of the attachment pane remained the same as that of the the original email.

I will follow-up with a snapshot of this problem soon.

UPDATE
------
Whilst trying to make an attachment to accompany the "Steps to reproduce" section, it has become apparent that this can be reproduced by just opening a saved email that contains attachments,

Reproducible: Always

Steps to Reproduce:
1. Save the file named "cygwin Digest 1 Jan 2006 06 32 45 -0000 Issue 4711.eml" attached with this bug.
2. Click on the "Open Saved Message..." menu-item under the "File" menu, and choose the saved file from 1.
3. Observe the size of the text and attachment panes of the message window (maximized or not).


Actual Results:  
The text pane allows for only about 5 lines, while the attachment pane takes up a large majority of the viewable area of the window. The pane takes up a lot of unused space.

Expected Results:  
The attachment pane take up a reasonable size, perhaps just the maximum necessary to display the attachments, and/or be of adjustable size.
(Reporter)

Comment 1

12 years ago
Created attachment 207331 [details]
Email to help reproduce the problem.

Comment 2

12 years ago
(In reply to comment #0)
> In this standalone message
> window, the attachment list of the "original" digest email is visible. In my
> opinion, it is debatable whether this in itself is a bug or not.

Bug 203570.


> However, the bug I am reporting is that in this window, the attachment list
> pane grows to take up an extremely large portion of the message window. Too
> large, as it results in a very tiny visible area for the text of the email.
> This requires scrolling. There is no way to adjust the size of the pane
> either, which perhaps could be considered another bug.

Is this not bug 223340?  If you agree, please mark this bug as a dupe of that one.


> This is also a regression from the 1.0 series of Thunderbird. In that
> series, the size of the attachment pane remained the same as that of the the
> original email.

I do not see different behavior between TB 1.0 and TB 1.5.  Did you have extensions installed under 1.0 which might have caused a difference?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> (In reply to comment #0)
> Is this not bug 223340?  If you agree, please mark this bug as a dupe of that
> one.

Yes, you are right. Will mark as duplicate accordingly.

> > This is also a regression from the 1.0 series of Thunderbird. In that
> > series, the size of the attachment pane remained the same as that of the the
> > original email.
> 
> I do not see different behavior between TB 1.0 and TB 1.5.  Did you have
> extensions installed under 1.0 which might have caused a difference?

No, no extensions. Pretty sure about the regression.


*** This bug has been marked as a duplicate of 223340 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.