Crash if I close/query a bug, Bugzilla has suffered an internal error

VERIFIED INVALID

Status

()

--
trivial
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: eder, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

This is the message from Bugzilla:

undef error - DBD::mysql::st execute failed: Got error 127 from table handler [for Statement "SELECT profiles.realname AS name, profiles.login_name AS email, DATE_FORMAT(longdescs.bug_when, '%Y.%m.%d %H:%i') AS time, longdescs.thetext AS body, longdescs.work_time, isprivate, already_wrapped, DATE_FORMAT(longdescs.bug_when, '%Y%m%d%H%i%s') AS bug_when FROM longdescs, profiles WHERE profiles.userid = longdescs.who AND longdescs.bug_id = ? ORDER BY longdescs.bug_when asc"] at Bugzilla/Bug.pm line 785 Bugzilla::Bug::GetComments(3613) called at Bugzilla/Bug.pm line 443 Bugzilla::Bug::longdescs('Bugzilla::Bug=HASH(0x80c7368)') called at data/template/template/en/default/bug/edit.html.tmpl line 47 eval {...} called at data/template/template/en/default/bug/edit.html.tmpl line 47 eval {...} called at data/template/template/en/default/bug/edit.html.tmpl line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 140 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 138 Template::Document::process('Template::Document=HASH(0x8a4c838)','Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 350 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 320 Template::Context::process('Template::Context=HASH(0x8843854)','bug/edit.html.tmpl') called at data/template/template/en/default/bug/show.html.tmpl line 72 eval {...} called at data/template/template/en/default/bug/show.html.tmpl line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 140 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 138 Template::Document::process('Template::Document=HASH(0x895ccb4)','Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 350 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 320 Template::Context::process('Template::Context=HASH(0x8843854)','Template::Document=HASH(0x895ccb4)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Service.pm line 97 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Service.pm line 94 Template::Service::process('Template::Service=HASH(0x8818bb8)','bug/show.html.tmpl','HASH(0x805f778)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template.pm line 76 Template::process('Bugzilla::Template=HASH(0x87aa9f8)','bug/show.html.tmpl','HASH(0x805f778)') called at /var/www/html/bugsCBC/show_bug.cgi line 134

Reproducible: Always

Steps to Reproduce:
1. Just try to access a bug
2.
3.

Actual Results:  
undef error - DBD::mysql::st execute failed: Got error 127 from table handler [for Statement "SELECT profiles.realname AS name, profiles.login_name AS email, DATE_FORMAT(longdescs.bug_when, '%Y.%m.%d %H:%i') AS time, longdescs.thetext AS body, longdescs.work_time, isprivate, already_wrapped, DATE_FORMAT(longdescs.bug_when, '%Y%m%d%H%i%s') AS bug_when FROM longdescs, profiles WHERE profiles.userid = longdescs.who AND longdescs.bug_id = ? ORDER BY longdescs.bug_when asc"] at Bugzilla/Bug.pm line 785 Bugzilla::Bug::GetComments(3613) called at Bugzilla/Bug.pm line 443 Bugzilla::Bug::longdescs('Bugzilla::Bug=HASH(0x80c7368)') called at data/template/template/en/default/bug/edit.html.tmpl line 47 eval {...} called at data/template/template/en/default/bug/edit.html.tmpl line 47 eval {...} called at data/template/template/en/default/bug/edit.html.tmpl line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 140 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 138 Template::Document::process('Template::Document=HASH(0x8a4c838)','Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 350 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 320 Template::Context::process('Template::Context=HASH(0x8843854)','bug/edit.html.tmpl') called at data/template/template/en/default/bug/show.html.tmpl line 72 eval {...} called at data/template/template/en/default/bug/show.html.tmpl line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 140 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Document.pm line 138 Template::Document::process('Template::Document=HASH(0x895ccb4)','Template::Context=HASH(0x8843854)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 350 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Context.pm line 320 Template::Context::process('Template::Context=HASH(0x8843854)','Template::Document=HASH(0x895ccb4)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Service.pm line 97 eval {...} called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Service.pm line 94 Template::Service::process('Template::Service=HASH(0x8818bb8)','bug/show.html.tmpl','HASH(0x805f778)') called at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template.pm line 76 Template::process('Bugzilla::Template=HASH(0x87aa9f8)','bug/show.html.tmpl','HASH(0x805f778)') called at /var/www/html/bugsCBC/show_bug.cgi line 134

Expected Results:  
All details about my bug.

This error only occurs with some bugs.  And the problem started it appears of one hour for another one.

Comment 1

13 years ago
Which version of Bugzilla?
this is a mysql issue -- your database most probably needs repairing.

run the following queries:

  REPAIR TABLE longdescs
  REPAIR TABLE profiles

if you have any further issues/questions your best bet is to follow it up on the bugzilla support list.

--> invalid (not a bugzilla bug)

note:  the key phrase in the error message is "Got error 127 from table handler".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Severity: critical → trivial
You need to log in before you can comment on or make changes to this bug.