mail header list empty

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Dennis Esters, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: I do not know. I started the tool up and it asked me to restart because it had downloaded an update. so I did.

I have messages in most of my folders but the messages are not displayed.
also the folders that contain unread mail used to be bold, now they are plain font. I could tell they had unread mail because of the (number) at the end of the name but the folders appeared empty (ie no messages in the message header list)

I closed the application and restarted my 1.0.6 version and it is fine. I closed my 1.0.6 version and restarted the alpha version and there are now no folders.

Also the first time I ran the updated alpha version I could not access the Options menu item. When I can get the alpha version to launch I still can not access the options menu item.

Once when trying to start the application it died and sent a report of some kind to you guys. I don't know if that can ever be attached to this bug report or not.

As it stands the alpha version is completely useless to me.

Reproducible: Always

Steps to Reproduce:
1. start application
2. no folders, no messages.
3. close application
4. start stable version and eveything is fine.

Actual Results:  
no messages
no folders

Expected Results:  
system folders, personal folders, messages in the folders.

See the details info.

Comment 1

12 years ago
Which version are you talking about? 1.6a1?  If you don't know which, you're probably best off using the stable release, or 1.5 rc2. 

http://www.mozilla.org/products/thunderbird/releases/1.5.html

Comment 2

12 years ago
(In reply to comment #0)
> Once when trying to start the application it died and sent a report of some
> kind to you guys. I don't know if that can ever be attached to this bug report
> or not.

Trunk (1.6a) versions run after a 1.0/1.5 version will crash the first time -- this is a known problem, bug 306959.  

For future reference, it *is* possible to get an ID for the Talkback report: run this program:
 <tb program directory>\extensions\talkback@mozilla.org\components\talkback.exe
It should pop up a window with a list of all the incidents; you can copy the incident ID and post it to the relevant bug.
(Reporter)

Comment 3

12 years ago
I can't get very many of the menu items to do anything so I have not yet found a way of knowing which version it is exactly. But I did install it to a folder called MozillaThunderbird1.6a so I think it is at least some version of 1.6a. I do not remember if the version had a 1 next or not.

I switched to this alpha version to hopefully move past the bug where when the mail agent gets the list of messages still on the server it gets confused about which ones it has already downloaded and which ones are 'new'. To resolve this I have to use another tool to delete these already downloaded messages so that Thunderbird does not hang and then eventually timeout while attempting to get mail. But I think this is just the secondary problem because I am configured to NOT leave downloaded mail on the server. So if THAT part worked, I'd never have noticed the other fault. 

Is what I just said a known bug? Is there a configuration option I can select to reduce this likelihood? Is there something I am doing wrong?

Comment 4

12 years ago
(In reply to comment #3)
> I can't get very many of the menu items to do anything so I have not yet found
> a way of knowing which version it is exactly.

  Help | About


> I switched to this alpha version to hopefully move past the bug where when
> the mail agent gets the list of messages still on the server it gets
> confused about which ones it has already downloaded and which ones are
> 'new'. To resolve this I have to use another tool to delete these already
> downloaded messages so that Thunderbird does not hang and then eventually
> timeout while attempting to get mail. But I think this is just the
> secondary problem because I am configured to NOT leave downloaded mail on
> the server. So if THAT part worked, I'd never have noticed the other fault. 
> 
> Is what I just said a known bug? Is there a configuration option I can
> select to reduce this likelihood? Is there something I am doing wrong?

Bug 207109?  Bug 263142?
(Reporter)

Comment 5

12 years ago
Yes. Help/About is how I would get to the version information. but when I do that nothing happens.
Also, today it crashed twice while trying to start and now when it does come up, it only has the Folder menu and it has nothing on it. and I have now visible folders, messages, nor message contents. Just an empty three panel view but nothing else.

As for the other problem which I was hoping I could get to reproduce in the alpha version, it is similar in nature to these other bugs you listed but not close enough. tb says downloading 1 of 10 (just an example, its not 10 everytime) when actually I have like 25 messages. maybe 15 were downloaded on a previous mail check and the 10 are actual new messages (I have never verified this but I will the next time it happens) but the mail downloading hangs at the 1 of 10 and then times out. If there was someway to turn on a verbose log of the POP3 traffic then maybe I could help diagnose this. I used to write email software before I changed jobs. We put the pop/imap commands and responses (not the password) in a window that the user could bring up. does tb have that? it'd be great. i do think this is a uidl vs. internal message table problem.

Comment 6

12 years ago
(In reply to comment #5)
> If there was someway to turn on a verbose log of
> the POP3 traffic then maybe I could help diagnose this.

There is.  See:
  http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#pop

Comment 7

12 years ago
WFM 
Dennis reports he's gone back to 1.0.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.