editusers.cgi is changing the preferences to default when visited

RESOLVED WORKSFORME

Status

()

Bugzilla
Administration
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: inukoti , Praveen babu, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I am using the bugzilla 2.20 . I have admin and edituser priveleges. if i goto edituser.cgi ---> search for user ---> click on the user to change privilages..
if i dont change any thing and click back button , all privilages r lost , only default privilages available. 

Reproducible: Always

Steps to Reproduce:
1.click on user or goto editusers.cgi
2.Search for user  
3.click on the user to change privilages
4. click back button without modifying 
5. will have default privileges , other were lost

Actual Results:  
your privilages will be set to default privileges.

Expected Results:  
restore privileges (not default) if not modified. 

If the above bug is not fixed. i have to add all my priveleges again and again visiting the editusers.cgi

Comment 1

13 years ago
(In reply to comment #0)
> 4. click back button without modifying 

What you say is that you never click the "Update" button when editing a user? And you click either the "Back" button of your web browser or the "back to the user list" link at the bottom of your page? In both case, no change will be saved, as expected.

> 5. will have default privileges , other were lost

What are the "default privileges"??? The ones the user had before being edited? Or the ones a newly created user account gets?


In all cases, the only way to alter user privileges is by clicking the "Update" button. If you don't do it, no changes will be saved. And if you want to edit user privs again, you cannot go back, you have to search for this user again and click on his name as you did the first time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 2

13 years ago
>> 5. will have default privileges , other were lost
 
>What are the "default privileges"??? The ones the user had before being edited?
>Or the ones a newly created user account gets?
 
 
>In all cases, the only way to alter user privileges is by clicking the "Update"
>button. If you don't do it, no changes will be saved. And if you want to edit
>user privs again, you cannot go back, you have to search for this user again
>and click on his name as you did the first time.
 

if i edit users ( for example  my account itself) and i dont click update button i click "back to users" Hyperlink then afterwards i lost my privileges to edit users and i only now have default ( edit bugs , report bug ) privileges. It happened once again to me . please help
There is no "back to users" link... Are you talking about "back to the user list"?
Are you using a different language?
Do you have custom templates?
Did you modify templates or code?

How do you find out that you were thrown out of groups?
Does the user list show up if you press the "back to the user list" link, or do you get an error about insufficient permissions?
Is it possible that your browser's form autocompletion functionality alters the user edit form so that it looks like there were no group memberships?
Is it possible that you're looking at a different user, which is indeed in no further groups?

I really can't reproduce either.
(Reporter)

Comment 4

13 years ago
Created attachment 207480 [details]
Ans to all questions mail send on 04-1-05

Comment 5

13 years ago
This doesn't make sense. Clicking the "back to the user list" link doesn't alter the DB *at all*, so you cannot loose privileges that way.

If you have direct access to your MySQL DB, could you please try this SQL query:

SELECT profiles_activity.* FROM profiles_activity INNER JOIN profiles ON profiles.userid = profiles_activity.userid WHERE profiles.login_name = 'inukoti@teleaction.de';

If you cannot do it yourself, please ask the maintainer of the installation to run this query and paste the output here.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> This doesn't make sense. Clicking the "back to the user list" link doesn't
> alter the DB *at all*, so you cannot loose privileges that way.
> 
> If you have direct access to your MySQL DB, could you please try this SQL
> query:
> 
> SELECT profiles_activity.* FROM profiles_activity INNER JOIN profiles ON
> profiles.userid = profiles_activity.userid WHERE profiles.login_name =
> 'inukoti@teleaction.de';
> 
> If you cannot do it yourself, please ask the maintainer of the installation to
> run this query and paste the output here.
> 

I have executed the query ,no output, tried to select * from profiles_activity,  no result (table is empty). 

 I will try to make a movie and send to you may be it will help you in finding the fault, from my side. 
(Reporter)

Comment 7

13 years ago
I have made a movie with webcam so poor quality. just click the link below and donwload the movie. i tried to upload the movie to bugzilla , it wont accept more than 300k .

http://download.35mb.com/inukotip/bugzilla.wmv

Please donwload the movie and let me know where my fault is ?
I'm very sorry. What you're doing looks all right. It should work. I have no idea what's happening here :(

Because it works for me, I'm fairly sure, though, that what you're experiencing is not a Bugzilla error. Please try the options on http://www.bugzilla.org/support/ -- maybe you'll have more luck there finding out what's going on.

Comment 9

13 years ago
(In reply to comment #7)
> http://download.35mb.com/inukotip/bugzilla.wmv

The fact that profiles_activity is empty proves that editusers.cgi is not changing your privileges, else it would be recorded there.

Moreover, the link above contains adware, which my antivirus software didn't like! And so I couldn't view it. But I trust Marc and if he says that's probably not a Bugzilla bug, then the best thing to do is to follow the link he gave.

Marking WFM again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.