Crash at [@ nsMsgQuickSearchDBView::ListIdsInThread]

RESOLVED FIXED in Thunderbird2.0

Status

RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: mscott, Assigned: Bienvenu)

Tracking

({fixed1.8.0.2, fixed1.8.1, topcrash})

Thunderbird2.0
x86
Windows XP
fixed1.8.0.2, fixed1.8.1, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Updated

13 years ago
Keywords: topcrash
Target Milestone: --- → Thunderbird2.0

Comment 1

13 years ago
Incident ID: 13514136
Stack Signature	nsMsgQuickSearchDBView::ListIdsInThread aa065dfd
Product ID	Thunderbird15
Build ID	2005120115
Trigger Time	2006-01-02 19:31:16.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	thunderbird.exe + (00466e43)
URL visited	
User Comments	went to deleted message, searched on the word 'bart' and that crashes the application
Since Last Crash	96 sec
Total Uptime	477805 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgQuickSearchDBView.cpp, line 350
Stack Trace 	
nsMsgQuickSearchDBView::ListIdsInThread  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgQuickSearchDBView.cpp, line 350]
nsMsgDBView::ExpandByIndex  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 4076]
nsMsgThreadedDBView::AddKeys  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgThreadedDBView.cpp, line 265]
nsMsgThreadedDBView::InitThreadedView  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgThreadedDBView.cpp, line 152]
nsMsgQuickSearchDBView::Open  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgQuickSearchDBView.cpp, line 69]
XPTC_InvokeByIndex  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2139]
XPC_WN_CallMethod  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1444]
js_Invoke  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 1177]
js_Interpret  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 3523]
js_Execute  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c, line 1424]
JS_EvaluateUCScriptForPrincipals  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsapi.c, line 4103]
nsJSContext::EvaluateString  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1061]
nsGlobalWindow::RunTimeout  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6285]
nsGlobalWindow::TimerCallback  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6656]
nsAppStartup::Run  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mail/app/nsMailApp.cpp, line 62]
kernel32.dll + 0x16d4f (0x7c816d4f)

Comment 2

13 years ago
Created attachment 207471 [details] [diff] [review]
proposal
Attachment #207471 - Flags: review?

Updated

13 years ago
Attachment #207471 - Flags: review? → review?(bienvenu)
(Assignee)

Comment 3

13 years ago
Comment on attachment 207471 [details] [diff] [review]
proposal

thx, timeless. I've checked in a variation on this, using NS_ENSURE_SUCCESS(rv, rv); I was not able to reproduce this problem, but I've checked that this particular call site shouldn't care if we return an error.
Attachment #207471 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 4

13 years ago
Comment on attachment 207471 [details] [diff] [review]
proposal

fix checked in. We'll have to see if it fixes instances of this crash. We'd consider it for 1.8.0.1 when we start taking fixes for tb 1.5.0.1
Attachment #207471 - Flags: approval1.8.1?
(Assignee)

Comment 5

13 years ago
hey, scott, can I get approval for 1.8.1 for this?
(Reporter)

Updated

13 years ago
Attachment #207471 - Flags: approval1.8.1?
Attachment #207471 - Flags: approval1.8.1+
Attachment #207471 - Flags: approval1.8.0.2?
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Attachment #207471 - Flags: approval1.8.0.2? → approval1.8.0.2+
(Reporter)

Updated

13 years ago
Keywords: fixed1.8.0.2
Tough for QA to verify this one, but we should watch the talkback data once TB 1.5.0.2 ships.
Crash Signature: [@ nsMsgQuickSearchDBView::ListIdsInThread]
You need to log in before you can comment on or make changes to this bug.