When submitting a PHP form, the form is being submitted twice

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: bdykstra, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060104 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060104 Firefox/1.6a1

When submitting a PHP FORM, the form is being submitted twice.
The first submission contains all of the completed FORM elements, which are processed correctly by the PHP server.   The form is then submitted a second time, with NO form elements (not blank elements - no elements).
This double submission confuses the php application in the background, of course.

This bug began with the release of Firefox 1.5.  The PHP app always worked fine in prior versions of Firefox (at least as recently as a couple of months ago - the web app was not used for the last couple of months, so I cannot be sure that the latest pre 1.5 releases of Firefox did not contain this issue).
I can assure you that the PHP application has not been modified.

The PHP application logs show me when the page is accessed, and I have added some debugging that allows me to verify that the first submission includes the proper form fields, and the second submission does NOT contain the form fields.

Please note that I can reproduce this error in Firefox 1.5, as well as in the latest "Deer Park Alpha 2" release (today's release) and in Mozilla (application suite).  If I access the web application using Internet Explorer, or using Firefox with the "IE Tab" extension in IE mode, it works CORRECTLY.

Unfortunately the application is a secure (login required) app.  If necessary, I can get access to the application, with a test environment, for you to test the issue.  I can also get you access to all the log files.


Reproducible: Always

Steps to Reproduce:
1.  Go to web application (www.orilliacrc.com, choose Schedules), login, and submit the form in question.

Actual Results:  
for is submitted twice.
Here's a sample log entry:

04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php]: Accessed.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra): Form Field Found: [selected_names]
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra): Form Field Found: [x]
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra): Form Field Found: [y]
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Number of names selected: [5].
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Original number of names: [0].
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra): Saving new name list for schedule: Greeters Schedule...
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Adding name to members table: Baird, Frances.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Adding name to members table: Baird, Norman.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Adding name to members table: Bergsma, John.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Adding name to members table: Bergsma, Siep.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Adding name to members table: Bouwhuis, Marianne.

~~~ NOTE ~~~ 
here is where the second submission begins.  Because there
are no form fields, the app deletes the names that were added above, because
the names appear to no longer be selected in the form's SELECT list.
~~~ end of note ~~~

04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php]: Accessed.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Number of names selected: [0].
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Original number of names: [5].
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra): Saving new name list for schedule: Greeters Schedule...
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name Removed: Baird, Frances
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name was removed from members table.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name Removed: Baird, Norman
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name was removed from members table.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name Removed: Bergsma, John
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name was removed from members table.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name Removed: Bergsma, Siep
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name was removed from members table.
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name Removed: Bouwhuis, Marianne
04-Jan-2006 13:05:43 [69.198.217.252][/v2_schedules/edit_name_list.php] (bdykstra):   Name was removed from members table.
0



Expected Results:  
Only one form submission.

Please let me know if you require any other information.

Thanks,

Bill

bdykstra@gmail.com

Comment 1

13 years ago
==> form submission

could you be seeing bug 61363 or what's decsribed in bug 316731 comment 5?
Assignee: general → form-submission
Component: General → HTML: Form Submission
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
Thanks for the reply.

This does not appear to be either of those situations.
It's possible that this is related to bug 316731 comment 5, but I don't seem to see any "empty" <img src=""> or background-image:url() statements.   I can confirm that what I'm seeing is first a POST followed by a GET.  I added some PHP code to verify that, so that may shed a little light on the situation.
I'll keep digging around.

Thanks again.
Bill

Comment 3

10 years ago
I experience a similar problem when I use jQuery's Datepicker. Only in Firefox (using version 3.0.3). All fields are submitted twice. Happens every time.

Comment 4

9 years ago
I can't reproduce this with FF 3.5.1 on Windows Vista. Can anyone else?
Assignee: form-submission → nobody
QA Contact: ian → form-submission
Is this still an issue ?
Flags: needinfo?(bdykstra)

Comment 6

6 years ago
I haven't noticed this problem in a long while.
marking worksforme, please open a new bug if this still happens.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

6 years ago
Agreed, this is no longer an issue.
Flags: needinfo?(bdykstra)
You need to log in before you can comment on or make changes to this bug.