small download window (w/ indicator bar) slow to appear when lots of existing files in dl folder

RESOLVED DUPLICATE of bug 240525

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 240525
13 years ago
10 years ago

People

(Reporter: Steven Neil Groginsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I see data being transferred on a graphic connection meter a good 5 or 10 seconds before the small download box appears showing the file being transferred.

I believe this might be caused by code that is reading the big download folder (many files) from disk before it shows the window.

Reproducible: Always

Steps to Reproduce:
1.click on a download link to any file
2.see data downloading on connection meter (external)
3.wait for small download window to appear

Actual Results:  
Wait 5-10 seconds after clicking on link for small download window to appear

Expected Results:  
Small download window should have better response on an Athlon XP 1700+ (1.47 GHz).  Hard disk files are almost completely contiguous, hd is 7200? rpm.  Using DMA IDE interface, ATA 100.


Is there an XP hd write routine that just adds a file without looking through the whole download folder?

btw, my current e-mail is sgrog@gmail.com.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 240525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.