Setting opacity < 1 on .statusbarpanel-icon in a .statusbar-menu-icon makes it so the menu doesn't appear when the icon is clicked on

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: jason.barnabe, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

545 bytes, application/vnd.mozilla.xul+xml
Details
Reporter

Description

14 years ago
If you set .statusbarpanel-icon's opacity to something lower than 1 in a statusbarpanel with a menu, clicking directly on the icon doesn't display the menu. Clicking in the space between the icon and the edge of the panel displays the menu just fine. visibility: hidden instead of opacity works fine too.
Reporter

Comment 1

14 years ago
Posted file testcase

Comment 2

14 years ago
Maybe dupe of Bug 293977.
Yeah, same issue (views inside XUL widgets).
This is WFM in my debug build that has the "frame display lists" patch in it
(bug 317375)
Depends on: 317375
Testcase doesn't work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 ID:2006012405

Testcase does work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613

Fixed by bug 317375

--> RESOLVED FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.