Closed Bug 322443 Opened 15 years ago Closed 14 years ago

{inc} BasicTablelayoutStrategy Balance missing with incr. reflow

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: cws, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

In some rare case ( I my case, i set column width of the table
on the second row, not the first) SCRIPT tag with SRC case the page
to render incorrectly.

Reproducible: Always

Steps to Reproduce:
1.access the page
2.
3.
Attached file testcase
With the document.body.offsetHeight hack you get the same effect.
See:
http://weblogs.mozillazine.org/hyatt/archives/2003_08.html#003963
Iirc, this is a duplicate of an already filed bug.
Component: General → Layout: Tables
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk
This bug has a fairly nice testcase, renaming it a little bit
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: SCRIPT tag with SRC attribute cause firefox to render the page incorrectly → {inc} BasicTablelayoutStrategy Balance missing with incr. reflow
Weirdness observed with:
-  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a
(Two tables are not the same until you resize the fonts on the page, or some other way of making the page reflow)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1
(Two tables are the same)

-->RESOLVED FIXED 
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.