Closed Bug 322480 Opened 15 years ago Closed 15 years ago

Yahoo! Mail Beta crashes while logging in [@ js3250.dll]

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: u88484, Unassigned)

References

()

Details

(Keywords: crash, regression, top100)

Crash Data

Log into Yahoo! Mail Beta, during logging in Firefox crashes
TB13602932Z
TB13602869K

Stack Signature	 js3250.dll + 0x2d12 (0x60082d12) 1bebd9f5
Product ID	FirefoxTrunk
Build ID	2006010505
Trigger Time	2006-01-05 06:55:22.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	js3250.dll + (00002d12)
URL visited	
User Comments	
Since Last Crash	54 sec
Total Uptime	120 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
js3250.dll + 0x2d12 (0x60082d12)
FIREFOX.EXE + 0xa1045 (0x004a1045)
FIREFOX.EXE + 0xa107a (0x004a107a)
FIREFOX.EXE + 0xa1120 (0x004a1120)
FIREFOX.EXE + 0xa08b6 (0x004a08b6)
FIREFOX.EXE + 0x1319ee (0x005319ee)
FIREFOX.EXE + 0x178080 (0x00578080)
FIREFOX.EXE + 0x18f76a (0x0058f76a)
FIREFOX.EXE + 0x18c1a1 (0x0058c1a1)
FIREFOX.EXE + 0x18bf44 (0x0058bf44)
FIREFOX.EXE + 0x1a0afb (0x005a0afb)
FIREFOX.EXE + 0x1a04e5 (0x005a04e5)
FIREFOX.EXE + 0x19bd7f (0x0059bd7f)
FIREFOX.EXE + 0x19b7f2 (0x0059b7f2)
FIREFOX.EXE + 0x1ec66e (0x005ec66e)
FIREFOX.EXE + 0x1eb7cd (0x005eb7cd)
FIREFOX.EXE + 0x2342f7 (0x006342f7)
FIREFOX.EXE + 0x108707 (0x00508707)
FIREFOX.EXE + 0x10cf04 (0x0050cf04)
FIREFOX.EXE + 0x10d351 (0x0050d351)
FIREFOX.EXE + 0x108ac4 (0x00508ac4)
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0x89cd (0x77d489cd)
USER32.dll + 0x8a10 (0x77d48a10)
FIREFOX.EXE + 0x11459e (0x0051459e)
FIREFOX.EXE + 0x465497 (0x00865497)
FIREFOX.EXE + 0x1013 (0x00401013)
kernel32.dll + 0x16d4f (0x7c816d4f)

Reproduceable: Everytime

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060105 Firefox/1.6a1

*** This bug has been marked as a duplicate of 322363 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Not a duplicate, no pYState.dll installed on reporter's system.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Narrowing down the regression window a little. I would find the regression window but don't have time at work and won't at home for a few days.

From mozzilazine post:
works with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a1) Gecko/20051231 Firefox/1.6a1

crashes with the first nighlty available after pacifica bustage 20060103
same regressionwindow for Bug 322504 [@ nspr4.dll][@ js3250.dll]
*** Bug 322504 has been marked as a duplicate of this bug. ***
Summary: Yahoo! Mail Beta crashes @ [js3250.dll] → Yahoo! Mail Beta crashes while logging in [@ js3250.dll]
Confirmed here, even in -safe-mode
Am also seeing ill effects from the same regression window in bug 322414
I fairly often (but randomly crash when closing FF)

Incident ID: 13632066
Stack Signature	nspr4.dll + 0x16879 (0x60156879) 9c23a49a
Product ID	FirefoxTrunk
Build ID	2006010505
Trigger Time	2006-01-06 01:08:32.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	nspr4.dll + (00016879)
URL visited	
User Comments	crash on exit
Since Last Crash	59685 sec
Total Uptime	59685 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
nspr4.dll + 0x16879 (0x60156879)
js3250.dll + 0x1dff9 (0x6009dff9)
js3250.dll + 0x1d9a0 (0x6009d9a0)
firefox.exe + 0x123b (0x0040123b)
firefox.exe + 0x1013 (0x00401013)
KERNEL32.dll + 0x28989 (0x7c598989)
Are the people crashing here all using adblock?
Browsing community.she.com, I get the following assertion multiple times on back/forward, but no crash:

WARNING: NS_ENSURE_TRUE(doc) failed, file C:/moz-debug/mozilla/modules/plugin/base/src/nsJSNPRuntime.cpp, line 238
###!!! ASSERTION: dangling entry->mJSObj JSPrivate because we can't find cx: 'Error', file C:/moz-debug/mozilla/modules/plugin/base/src/nsJSNPRuntime.cpp, line 1359
Forgot to mention I installed adblock to try and reproduce. I also just crashed with the following stack:

> _PR_MD_ATOMIC_DECREMENT(int * val=0x04d99344) Line 733 C
  PR_AtomicDecrement(int * val=0x04d99344) Line 310 + 0x9 C
  _releaseobject(NPObject * npobj=0x04d99340) Line 1521 + 0xd C++
  NPObjWrapper_Finalize(JSContext * cx=0x03b08890, JSObject * obj=0x05d48fb0) Line 1203 + 0x9 C++
  js_FinalizeObject(JSContext * cx=0x03b08890, JSObject * obj=0x05d48fb0) Line 2190 + 0x60 C
  js_GC(JSContext * cx=0x03b08890, unsigned int gcflags=0) Line 1847 + 0xb C
  js_ForceGC(JSContext * cx=0x03b08890, unsigned int gcflags=0) Line 1510 + 0xd C
  JS_GC(JSContext * cx=0x03b08890) Line 1830 + 0xb C
  nsJSContext::Notify(nsITimer * timer=0x0400c110) Line 2158 + 0xd C++
  nsTimerImpl::Fire() Line 404 C++
  nsTimerManager::FireNextIdleTimer() Line 636 C++
  nsAppShell::Run() Line 142 C++
  nsAppStartup::Run() Line 161 + 0x1a C++
  XRE_main(int argc=3, char * * argv=0x003e7540, const nsXREAppData * aAppData=0x00403090) Line 2297 + 0x23 C++
  main(int argc=3, char * * argv=0x003e7540) Line 61 + 0x13 C++
(In reply to comment #8)
> Are the people crashing here all using adblock?
> 
Adblock 0.5.2.056 (default from a.m.o) , no filterset G or regexp filters
(In reply to comment #8)
> Are the people crashing here all using adblock?
> 

Nope, I have never installed adblock.
Using Adblock Plus 0.5.11.1
Filterset.G [2005-12-11a]
Filterset.G Whitelist [2005-10-31a]
(In reply to comment #8)
> Are the people crashing here all using adblock?
> 
Reasserting comment #6, I get this in safe-mode, so no extensions.
Depends on: 322414
So how would I reproduce this?  In particular, what/where is Yahoo Mail Beta?
Flags: blocking1.9a1?
This just started for me today on the branch.  I get crashes about half of the time I visit Yahoo Mail (beta).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060106 Firefox/1.5
(In reply to comment #17)
> This just started for me today on the branch.  I get crashes about half of
> the time I visit Yahoo Mail (beta).
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060106
> Firefox/1.5
> 
This may be a compatibilityproblem with Yahoo Firefox Toolbar ver. 1.0.1.20050805 (By Yahoo)
Try "Yahoo Mail Notifier ver 0.9.2 " from http://addons/mozilla.org/
(crashes on both Mac/Win reported on branch)
The Mac crash was at [@ nsScriptSecurityManager::CheckSameOriginPrincipalInternal()] so it might be a different issue.
see http://forums.mozillazine.org/viewtopic.php?p=2000939#2000939

(In reply to comment #16)
> So how would I reproduce this?  In particular, what/where is Yahoo Mail Beta?
> 

I think this will work. Donno if just Yahoo's Mail Plus customers get access or not.

http://mrd.mail.yahoo.com/landing
fyi, bug 322722 was just submitted on OSX for 1.5.0.1 starting 1/7 -- curiously similar (xpcom+js & ymail beta) - perhaps a backported fix and it has a narrow regression window.
I think this still counts as a top100 even though that portion is in beta.
Keywords: top100
> I think this will work.

So I load that page... and then what?  Just log in and that should crash?  Do I need to do something special?  e.g., is it OK if I paste in the username and password?  Or do I have to type them?

That is, what are step by step steps to reproduce, including what I should type where, how I should submit forms (click on submit button vs enter), etc?
Blocks: 322683
(In reply to comment #22)

The link Kurt supplied in comment #16 is to the page that lets Yahoo Mail Plus customers switch to the beta version.
Once you have switched to the beta version, the browser will crash anytime you goto http://mail.yahoo.com

I'm not sure Yahoo (free) mail customers can use the beta yet.
I see.  Given that I'm not a Yahoo customer of any sort, is there a sane way I can debug this?

Toby Elliott, do you know whether there's a test account of some sort I can use?  Or know who might know?
No longer blocks: 322683
Depends on: 322683
I'm betting this is bug 322683 in a different guise.  Should retest once that's fixed.
Please retest in tomorrow's builds, now that bug 322683 is fixed?
This is fixed. Can someone mark as verified fixed? Donno who is allowed to do that, thought anyone with canedit privs could.
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Flags: blocking1.9a1?
Crash Signature: [@ js3250.dll]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.