Address Book Import for non-ascii entries is not working in .TAB or TXT format

VERIFIED FIXED in M17

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: marina, Assigned: chuang)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When importing Address Book containing non-ascii ab cards in tab or txt format 
all non-ascii input is trancated after the ascii chars.
Steps to reproduce:
-go to 4.x and Export AB with non-ascii entries;
-in Seamonkey open the Address Book, go File|Import and import this AB chosing 
cvs or txt format;
//note: on the left thread pane the name of the AB is displaying  correctly all 
non-ascii chars but this is not true for address book cards in the right thread: 
they are truncated after the ascii chars
(the Import works OK for LDIF format and i don't see any AB showing up in CVS 
format, it doesn't look like this feature is working)
**** observed with 2000-03-17 build ****

Comment 1

19 years ago
same problem on linux. Changed platform to all.
Hardware: PC → All
Summary: Address Book Import for non-ascii entries is not working in .TAB or TXT format → Address Book Import for non-ascii entries is not working in .TAB or TXT format

Comment 2

19 years ago
Sending to Candice.
Assignee: hangas → chuang

Comment 3

19 years ago
Marking M16 (not M15 stopper)
Target Milestone: --- → M16

Comment 4

19 years ago
Mail Review recommends beta2 stopper.
Keywords: nsbeta2

Comment 5

19 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 6

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 7

19 years ago
Can I get a sample file?  The tab file exported from 4.x would be fine.
(Reporter)

Comment 8

19 years ago
Created attachment 9442 [details]
Address book with non-ascii entries
(Reporter)

Comment 9

19 years ago
Actually in 2000-06-01 i see the correct display of non-ascii after importing 
txt or tb delimited format, the only problem i still see is the one described in 
bug report # 32931.
(Assignee)

Comment 10

19 years ago
So, can we mark this one as fixed?
(Reporter)

Comment 11

19 years ago
yes, let's mark it fixed for now and i'll keep eye on it and if it will 
re-emerge i will reopen.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

19 years ago
Resolve as fixed since it works now.

Comment 13

19 years ago
Kat - can you verify?

Comment 14

19 years ago
I'll put in on my radar.
QA Contact: lchiang → momoi

Comment 15

19 years ago
ji, please help out.
QA Contact: momoi → ji

Comment 16

19 years ago
Verified with 2000-07-26-09 builds.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.