Closed Bug 322512 Opened 15 years ago Closed 14 years ago

Removing span keeps spans below it from updating correctly

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: tklancer, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I have a set of spans inside an outer span.  Inside each span, there's a select dropdown with a list of options.  When I add an option to each of the dropdowns and then remove one of the spans with removeChild(), the new options do not display for spans *below* the removed one.  The new options display fine for spans above the removed one, however.

Reproducible: Always

Steps to Reproduce:
1. Load up the attached file
2. Click "Remove Row" for the 2nd row (the one with "DEF" selected)
3. Check the dropdowns for all remaining rows.
Actual Results:  
The first row has a new item named "NewAddition" in the dropdown, but the following two do not.

Expected Results:  
All rows should have a new item named "NewAddition" in their dropdown

This is definitely related to the removeChild() call on line 21.  It appears to behave the same if I clear out the innerHTML of the span to be removed, as well.  Not that I particularly want to use IE as an example of what to do, but this behaves correctly in IE.
OK, so, Bugzilla won't let me attach my file.  I've put it up here: http://tklancer.net/firefoxBug.html
Attached file testcase
Testcase attached to the bug.
This is clearly a bug in Mozilla, when adding var x=document.body.offsetHeight in the loop, the bug disappears.
The bug can also be seen in Mozilla1.7.
Status: UNCONFIRMED → NEW
Component: General → Layout: Form Controls
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → Trunk
Looks like the reflow branch landing fixed this.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.