Cursoring over tabs in an edit field crashes Firefox.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Sy Ali, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050317 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050317 Firefox/1.0.7

Firefox crashes if I paste text that includes tabs into an edit field, and then edit that text.

Reproducible: Always

Steps to Reproduce:
1. Get to an edit box
2. Paste some text which includes tabs
3. Cursor left and right through this text, typing or cutting-and-pasting.

Actual Results:  
At some point Firefox will bomb out, with no error message.

Expected Results:  
Editing should continue as normal.

I don't have talkback enabled on my build.  I'd be willing to experiment and report in more detail if this is not easily reproducable by others.
(Reporter)

Comment 1

13 years ago
I haven't tried to reproduce this in safe mode yet.  I'll do that if asked: http://kb.mozillazine.org/Safe_mode
Could you try Firefox1.5?
(Reporter)

Comment 3

13 years ago
Yes, I'll do that this evening/weekend.  I didn't realise 1.5 was out.. it's not available with the mainstream packages for my distro yet.
(Reporter)

Comment 4

13 years ago
It looks like I can't reproduce this in 1.5 under similar circumstances.  =)

Marking worksforme, will re-open if I ever reproduce this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.