Trying to install XPI file locally hangs browsers

RESOLVED INVALID

Status

SeaMonkey
Installer
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Dan, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060105 MultiZilla/1.8.1.0p SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060105 MultiZilla/1.8.1.0p SeaMonkey/1.5a

When trying to install a XPI installer package by dragging and dropping or through file-open, the browser hangs

Reproducible: Always

Steps to Reproduce:
1. drag xpi file into browser window or
1. file-open file->point to xpi file

Actual Results:  
browser hangs

Expected Results:  
bring up install prompt
(Reporter)

Comment 1

13 years ago
Seems that this bug only manifests itself if Multizilla was previously used. Commenting out the multizilla preferences in prefs.js allows the installation of xpi packages again. This is the first time I've had to to this going from nightly to nightly.
Severity: critical → normal

Comment 2

13 years ago
Have you checked the Multizilla bug database http://multizilla.mozdev.org/bugs.html ?
Version: unspecified → Trunk

Comment 3

10 years ago
Yes, I have noticed before that Multizilla adds some potentially destructive stuff to prefs.js, so I also think this is caused by that extension and not a bug in SeaMonkey. I haven't found any other bugs about similar things and nobody CC'd himself to this bug so I mark this invalid.

Dan, if you can reproduce this with current versions of an extension and an unbroken prefs.js, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: general
You need to log in before you can comment on or make changes to this bug.