If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox does not attempt to retrieve directory listing

RESOLVED WORKSFORME

Status

()

Core
Networking: FTP
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Douglas Price, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

See discussion forum topic here:
http://forums.rhinosoft.com/showthread.php?t=377

Basically, Firefox never attempts to retrieve a file/directory listing from an FTP site after log in.  It doesn't matter if the it tries the anonymous account or using a named account (i.e. ftp://username@password:ftp.site.com/

Firfox only sends these commands:
USER anonymous
PASS mozilla@example.com
SYST
PWD
TYPE I
PASV
SIZE /

Then it reports "The connection was reset
The connection to the server was reset while the page was loading."

After Firefox sends the "SIZE /" command (which doesn't make any sense...) it hangs up.  The software should be able to determine the difference between a file and a directory.  The server does send back UNIX file permissions that does indicate whether or not an item is a directory or not.

Other browsers (Internet Explorer and older versions of Netscape) successfully log in by sending these commands:
USER anonymous
PASS IEUser@my.net
SYST
PWD
PASV
TYPE I
SIZE /
MDTM /
CWD /
LIST

The "LIST" command makes sense as it returns a list of files and directories.


Reproducible: Always

Steps to Reproduce:
1. In Firefox, Go to ftp://ftp.price-net.net/
2. 
3.

Actual Results:  
Here's a screen capture of the results.
http://www.price-net.net/firefox_ftp/error.gif

Expected Results:  
Produce a listing of files and directories as in this screen capture (Netscape 4.79):
http://www.price-net.net/firefox_ftp/success.gif



FTP Server software is Serv-U 6.1.0.5 Corporate Edition
Running on Win XP Pro SP2 dual Opteron server via cable modem
Been running FTP servers since 1998 with no problems...transfer ~3GB daily
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060105 Firefox/1.6a1 ID:2006010522

WFM. I see this in all old and new builds: http://img474.imageshack.us/my.php?image=ftp6ib.png
Assignee: nobody → dougt
Component: File Handling → Networking: FTP
Product: Firefox → Core
QA Contact: file.handling → benc
Version: unspecified → 1.8 Branch

Comment 2

12 years ago
WFM - though the ftp server is a bit slow to return any data.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060106 Firefox/1.6a1

Comment 3

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

WFM as well (though the server is slow to respond).
(Reporter)

Comment 4

12 years ago
The only reason is it acts slow is that I only have a 512kbps pipe and the server stays fairly busy.

If people are able to receive a directory listing using Firefox, then why do I get complaints from other Firefox users?  My primary issue with it was with the commands it sends (or doesn't send) to the server.


Component: Networking: FTP → File Handling
Product: Core → Firefox
Version: 1.8 Branch → 1.0 Branch
Assignee: dougt → nobody
Component: File Handling → Networking: FTP
Product: Firefox → Core
QA Contact: benc → networking.ftp
Version: 1.0 Branch → Trunk
Reporter, do you still see this problem with Firefox 2.0? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME
(Reporter)

Comment 6

10 years ago
Seems that this issue was resolved with the 2.x series.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.