crash [thunderbird.exe + 0x127215 (0x00527215)] after sending, closing compose or draft window

RESOLVED DUPLICATE of bug 316176

Status

--
critical
RESOLVED DUPLICATE of bug 316176
13 years ago
13 years ago

People

(Reporter: wsmwk, Assigned: mscott)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
updated from trunk version 1.6a1 (20051206) to 20060105.  had performance problem forwarding a message, so turned off check spell as you type.

at some point after installing 20060105, closing compose window crashed (closing a draft or after send completes).  only happens with one of my two imap accounts - one account runs clean, the other account fails 100%  (also, rarely, talkback was not invoked)

Steps:
1. compose
2. send
3. crash

OR
1. compose
2. save draft
3. close
4. crash

Went back to 20051206 and had no problems.  Went back to 20060105 and now no problems.

3 talkbacks here (but there were many more crashes than these 3):
TB13647350  
TB13647351
TB13163270 very similar, but happened on version 1.6a1 (20051206) 

Some similar crashes from others:
TB13461815 build 2005121904
TB13518326 build 2005121904
TB13605650


Incident ID: 13163270
Stack Signature	thunderbird.exe + 0x6b0fd5 (0x00ab0fd5) 5b905917
Product ID	ThunderbirdTrunk
Build ID	2005120605
Trigger Time	2005-12-20 11:52:10.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	thunderbird.exe + (006b0fd5)
URL visited	
User Comments	closing a compose window - a draft message s/vseerror
Since Last Crash	991917 sec
Total Uptime	991917 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
thunderbird.exe + 0x6b0fd5 (0x00ab0fd5)
thunderbird.exe + 0x3721de (0x007721de)
thunderbird.exe + 0x3725c3 (0x007725c3)
thunderbird.exe + 0x3be3a7 (0x007be3a7)
thunderbird.exe + 0x1013 (0x00401013)
KERNEL32.dll + 0x28989 (0x7c598989)


Incident ID: 13647350
Stack Signature	thunderbird.exe + 0x127215 (0x00527215) a6e67ab2
Product ID	ThunderbirdTrunk
Build ID	2006010509
Trigger Time	2006-01-06 10:31:02.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	thunderbird.exe + (00127215)
URL visited	
User Comments	
Since Last Crash	15199 sec
Total Uptime	15199 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
thunderbird.exe + 0x127215 (0x00527215)
thunderbird.exe + 0x1cd0c (0x0041cd0c)
js3250.dll + 0x24b90 (0x600b4b90)
js3250.dll + 0x1f142 (0x600af142)
thunderbird.exe + 0x2460d (0x0042460d)
thunderbird.exe + 0x22cc0 (0x00422cc0)
xpcom_core.dll + 0x390bb (0x603690bb)
xpcom_core.dll + 0x98ac (0x603398ac)
thunderbird.exe + 0x4693d (0x0044693d)
thunderbird.exe + 0x46da2 (0x00446da2)
xpcom_core.dll + 0x98ac (0x603398ac)
xpcom_core.dll + 0x7597 (0x60337597)
thunderbird.exe + 0x1242 (0x00401242)
thunderbird.exe + 0x1013 (0x00401013)
KERNEL32.dll + 0x28989 (0x7c598989)



Incident ID: 13647351
Stack Signature	thunderbird.exe + 0x127215 (0x00527215) a6e67ab2
Product ID	ThunderbirdTrunk
Build ID	2006010509
Trigger Time	2006-01-06 10:41:07.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	thunderbird.exe + (00127215)
URL visited	
User Comments	sending a message. s/vseerror
Since Last Crash	587 sec
Total Uptime	15786 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
thunderbird.exe + 0x127215 (0x00527215)
thunderbird.exe + 0x1cd0c (0x0041cd0c)
js3250.dll + 0x24b90 (0x600b4b90)
js3250.dll + 0x1f142 (0x600af142)
thunderbird.exe + 0x2460d (0x0042460d)
thunderbird.exe + 0x22cc0 (0x00422cc0)
xpcom_core.dll + 0x390bb (0x603690bb)
xpcom_core.dll + 0x98ac (0x603398ac)
thunderbird.exe + 0x4693d (0x0044693d)
thunderbird.exe + 0x46da2 (0x00446da2)
xpcom_core.dll + 0x98ac (0x603398ac)
xpcom_core.dll + 0x7597 (0x60337597)
thunderbird.exe + 0x1242 (0x00401242)
thunderbird.exe + 0x1013 (0x00401013)
KERNEL32.dll + 0x28989 (0x7c598989)

Comment 1

13 years ago
Those talkback IDs don't have symbols. If they do you would see function names instead of exes. Could you try reinstalling and see if you can IDs with symbols?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Those talkback IDs don't have symbols. If they do you would see function names
> instead of exes. Could you try reinstalling and see if you can IDs with
> symbols?

Is lack of symbols a result of something I did during installation or reporting?  Or is it because that exe/build or talkback server lacks the symbols?  Or, is there a third possible cause?

Comment 3

13 years ago
unless you hacked your build to force talkback into the wrong build, or you use a nighlty build that's over a week old, lack of symbols is usually our fault. if a release build experiences the same crash, it should be good enough to send a talkback for that as we should never release a release w/o working talkback.
(Reporter)

Comment 4

13 years ago
TB13799663K when it becomes available on talkback 4-5 hours from now.  version 1.6a1 (20060109)

Updated

13 years ago
Keywords: talkbackid
(Reporter)

Comment 5

13 years ago
SSL+imap, two imap accounts, filters on account A.

Reproducible: Always crashes in second account to be sent from.

Steps to Reproduce:
To reproduce bug:
1. start TB
2. Login account A
3. Login account B
4. compose mail from account A, send 
5. respond to password prompt
6. message sent
7. compose mail from account B, send 
8. respond to password prompt
9. crash sending from account B

restart TB
at step 4 start with account B (swap the accounts for each step)
9. crash sending from account A

TB13801900Q - started with account A, crashed account B
TB13802019K - started with account B, crashed account A
stacks are same as TB13799663K below

also tested after starting TB without extensions. Same results.


(In reply to comment #4)
> TB13799663K - version 1.6a1 (20060109)
same old crap with no symbols...

Incident ID: 13799663
Stack Signature	thunderbird.exe + 0x12804b (0x0052804b) a3837722
Product ID	ThunderbirdTrunk
Build ID	2006010908
Trigger Time	2006-01-10 14:19:40.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	thunderbird.exe + (0012804b)
URL visited	
User Comments	sent message - crashed near end of sending. s/vseerror
Since Last Crash	99398 sec
Total Uptime	99398 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
thunderbird.exe + 0x12804b (0x0052804b)
thunderbird.exe + 0x1ce10 (0x0041ce10)
js3250.dll + 0x24b9a (0x600b4b9a)
js3250.dll + 0x1f152 (0x600af152)
thunderbird.exe + 0x24731 (0x00424731)
thunderbird.exe + 0x22d87 (0x00422d87)
xpcom_core.dll + 0x390bb (0x603690bb)
xpcom_core.dll + 0x98ac (0x603398ac)
thunderbird.exe + 0x46b62 (0x00446b62)
thunderbird.exe + 0x46fc7 (0x00446fc7)
xpcom_core.dll + 0x98ac (0x603398ac)
xpcom_core.dll + 0x7597 (0x60337597)
thunderbird.exe + 0x1242 (0x00401242)
thunderbird.exe + 0x1013 (0x00401013)
KERNEL32.dll + 0x28989 (0x7c598989)
Keywords: talkbackid
(Reporter)

Comment 6

13 years ago
(In reply to comment #3)
> unless you hacked your build to force talkback into the wrong build, or you use
> a nighlty build that's over a week old, lack of symbols is usually our fault.

All - I've gone back and retested some nightly builds that are obviously older than 1 week. however, I've also run less than a week and still get no symbols.  And I haven't attempted any hacks.

How do I check to see if my tbird.exe is using the correct talkback extension? 


Comment 7

13 years ago
I first noticed symptoms like this with 1.6a1-1028; I was testing a trunk 
build for an unrelated fix that David Bienvenu had put in, and noticed the 
3pane window closing for no good reason when I'd close another window.  Some 
of those windows were standalone message windows, and no crash resulted; but 
at least once then, I saw a crash that was from a compose window being closed.  I've encountered similar crashes in the trunk ever since, more often on dismissing a compose window rather than sending the message -- but Send Later has caused the problem.  It doesn't happen every time, tho.

At the time I first noticed this, I exchanged mail with David, who wondered if the sudden closings was due to "the fix for TB not shutting down after a 
compose window was opened" -- bug 312135.  That bug's patch had to do with fixing things for a cached compose window -- which jibes with having a symptom that only happens occasionally.

Comment 8

13 years ago
CC'ing Benjamin, who wrote the patch for that other bug.
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> CC'ing Benjamin, who wrote the patch for that other bug.

bug 312135 patch landed 10/26 so it certainly is suspect.

I can trace this back to 1.6a1 (20051030) but no further. Is there a working archive location for nightly builds?  No new files after 10/3/05 at http://archive.mozilla.org/pub/thunderbird/nightly/

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 10

13 years ago
Without a usable stack or a very reproducable set of steps this is going to be hard for me to look at... unless it is a dup of bug 316176 which I promised to look at and haven't yet :-(
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> Without a usable stack or a very reproducable set of steps this is going to be
> hard for me to look at... unless it is a dup of bug 316176 which I promised to
> look at and haven't yet :-(

probably is the same bug.

I crashed on build 20060112 for example TB13891943 - but again sorry no symbols. I can't get symbols to save my soul. No idea what is going on. I've sent a message to Jay about the talkback server.
(Reporter)

Comment 12

13 years ago
now that I have symbols it looks like a dup. see bug 316176 comment 18

*** This bug has been marked as a duplicate of 316176 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.