Supported SVG Feature Strings are incorrect

RESOLVED FIXED

Status

()

Core
SVG
P2
normal
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Jeff Schiller, Assigned: longsonr)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

http://www.codedread.com/svgtest.svg shows that Firefox 1.5 claims to support the feature string http://www.w3.org/TR/SVG11/feature#SVGDOM.  However, the SVG 1.1 Full spec (http://www.w3.org/TR/SVG11/feature.html) states that for #SVGDOM "At least one of the following must be supported:
"http://www.w3.org/TR/SVG11/feature#SVGDOM-static", "http://www.w3.org/TR/SVG11/feature#SVGDOM-animation" or "http://www.w3.org/TR/SVG11/feature#SVGDOM-dynamic"

But none of these is supported by Firefox 1.5.  For instance, SVGDOM-static must support all the DOM interfaces for the static features, but not all DOM interfaces are supported (for instance SVGPathElement::replaceItem() method).

Reproducible: Always



Expected Results:  
SVGDOM feature string should not be supported
Flags: blocking1.9?

Updated

10 years ago
Flags: tracking1.9? → blocking1.9?
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Status: UNCONFIRMED → NEW
Ever confirmed: true
We should properly re-audit all our feature strings.

Comment 2

10 years ago
jwatt:  Do you want to own this?

Drivers:  This isn't a regression, are we sure we want it to block?
Nope.  -'ing.  If someone disagrees, feel free to give reasons why we should block.
Flags: blocking1.9+ → blocking1.9-
Assignee: general → nobody
QA Contact: ian → general

Updated

10 years ago
Duplicate of this bug: 426384
(Assignee)

Comment 5

10 years ago
Created attachment 313082 [details] [diff] [review]
patch

I've been through them all and here's my take on it.

ContainerAttribute - unsupported as we don't support enable-background
Image          - unsupported as it doesn't work with svg images
PaintAttribute - unsupported as we don't support color-interpolation
Cursor         - unsupported as we don't implement cursor elements
org.w3c.svg    - unsupported because it's dependent on other unsupported features
org.w3c.svg.lang - removed as it doesn't exist!
org.w3c.dom.svg - unsupported because it's dependent on other unsupported features
Attachment #313082 - Flags: review?(jwatt)
(Reporter)

Comment 6

10 years ago
Robert, can you clarify what isn't supported in the BasicFilter module?
(Assignee)

Comment 7

10 years ago
FilterPrimitiveWithIn.attrib we don't support all possible values of in.

in = "SourceGraphic | SourceAlpha | BackgroundImage | BackgroundAlpha  | FillPaint | StrokePaint | <filter-primitive-reference>"

and we only do SourceGraphic and SourceAlpha.
Comment on attachment 313082 [details] [diff] [review]
patch

Yup, looks good. r=jwatt
Attachment #313082 - Flags: review?(jwatt) → review+
(Assignee)

Updated

10 years ago
Attachment #313082 - Flags: superreview?(roc)
(Assignee)

Updated

10 years ago
Assignee: nobody → longsonr
Attachment #313082 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 9

10 years ago
Comment on attachment 313082 [details] [diff] [review]
patch

Makes our feature strings more accurate, unless we completely support all aspects of a feature we mark it unsupported.
Attachment #313082 - Flags: approval1.9?
As far as I'm concerned this blocks. It's a standards compliance issue and we defeat the purpose of feature strings if they can't be relied upon. The fix is very safe, so let's ship it.
Flags: blocking1.9- → blocking1.9+
(Assignee)

Updated

10 years ago
Attachment #313082 - Flags: approval1.9?
(Assignee)

Comment 11

10 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.